Putty server unexpectedly closed network connection

Discussion in 'Server Operation' started by Polk, Mar 26, 2009.

  1. Polk

    Polk New Member HowtoForge Supporter

    I'm getting this error in Putty:
    Server unexpectedly closed network connection

    Anyone knows how to fix it? All search results show to turn off UseDNS no but I'm not even using dns. I connect to IP directly. Anyway, tried that and it didn't work.

    I'm able to connect from other locations. just one computer got blocked. I can't find anything in logs, tried to reinstall ssh, ssh-openserver, fail2ban.

    I'm on Debian Lenny installed using Perfect Server manual.
     

    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

    How many failed login attempts did you make from this computer? I guess fail2ban is blocking that computer.
     
  3. Polk

    Polk New Member HowtoForge Supporter


    that's what I thought too. I did about 5 failed connections. I tried to uninstall fail2ban and also there was nothing in the iptables -L

    Any ideas?
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. Polk

    Polk New Member HowtoForge Supporter

    Thank you. I found that link online too. And followed the steps. I did not have blocked IP in my list.
    I also did apt-get remove fail2ban.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    And connecting from another IP works?
    Is the IP listed in /etc/hosts.deny?
     
  7. Polk

    Polk New Member HowtoForge Supporter

    Yes, I was able to connect from other IPs and yes, my blocked IP was listed there. Thank you so much! I removed and it's now working again!

    Thank you!
     
  8. sadnem

    sadnem New Member

    I post this just to inform people, my host was adding me automatically to /etc/hosts.deny so i had to erase my IP from /etc/hosts.deny and add it to /etc/hosts.allow I hope this can solve other people problems too ;)
     
  9. darkbeat

    darkbeat New Member

    hi im also having this problem when using smoothping putty.. can someon teach me how to fix it in much simplier instructions? hehe .. i already found tutorials on the web but sadly i find it really hard to understand T_T.. im using windows xp .. hope someone can help me
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Is your client IP listed in /etc/hosts.deny?

    Have you tried to reboot the system?
     

Share This Page