PureFTPd on ISPConfig 3 won't connect

Discussion in 'HOWTO-Related Questions' started by gawehner, Sep 18, 2009.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Here a few more points to check: You are sure you use FTP or FTPS and not SFTP for the connection? What do you get in auth.log and syslog file for the login and for a pure-ftpd-mysql restart? Did you try a reboot of the server and check that it's really pure-ftpd-mysql which listens on the ftp port? What is the exact connect log from ftp client and did you try another ftp client? Do you maybe use ftps and the ssl cert is missing or corrupted?
     
  2. Redwarp

    Redwarp New Member

    Im pretty sure on all the above yes, am stripped back to cli use of ftp command as we speak, the pureftp log in full (editted) is :
    Feb 21 17:58:20 saturn systemd[1]: Started pure-ftpd-mysql.service.
    Feb 21 17:58:20 saturn pure-ftpd: ([email protected]?) [DEBUG] Couldn't load the DH parameters file /etc/ssl/private/pure-ftpd-dhparams.pem
    Feb 21 17:58:41 saturn pure-ftpd: ([email protected]) [INFO] New connection from 5.9.200.180
    Feb 21 17:58:55 saturn pure-ftpd: ([email protected]) [DEBUG] Command [user] [XXXXXXXXXXXXXX]
    Feb 21 17:59:01 saturn pure-ftpd: ([email protected]) [DEBUG] Command [pass]
    Feb 21 17:59:05 saturn pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [XXXXXXXXXXXXX]
    Feb 21 17:59:05 saturn pure-ftpd: ([email protected]) [DEBUG] Command [syst] []
     
  3. Redwarp

    Redwarp New Member

    Humblest apologies Till and thanks for your help...was my fault in the end !!
    Recreated users & groups with the /etc files etc...missed a block of users off..so pure ftp was working perfectly just when it got to the end of its process & went to assign the user & group to the connection...it couldnt
    Uffff...thanks again
     

Share This Page