pureFTPd-mysql public_html woes

Discussion in 'HOWTO-Related Questions' started by d3th_n1gG4, Sep 17, 2006.

  1. d3th_n1gG4

    d3th_n1gG4 New Member

    Hi Guys,

    Firstly I'm a linux n00b so please be gentle :D

    I have recently started setting up our server running on debian 3.1 sarge, and got mysql, php and apache2 running off the bat (had some experience from a WAMP dev environment) then followed your How To on Proftp and mysql and couldn't get it to authenticate sso an apt-get --purge later i installed pureFTPd-mysql based on your tutorial, its running great, it creates my users homedirs etc like it should... go me ^^

    i have created a public_html symbolic link in my one users directory pointing to their /var/www/<username> directory and a std directory called test

    Now i can navigate test no problem using my ftpclient but when i have tried to nav public_html i get the following

    Command: CWD public_html
    Response: 550 Can't change directory to public_html: No such file or directory
    Error: Could not retrieve directory listing

    If i do a ls -l on the /home/<username> dir i get the following

    debian31m:/home/<username># ls -l
    total 4
    lrwxrwxrwx 1 <username> ftpgroup 18 2006-09-15 14:20 public_html -> /var/www/<username>/
    drwxr-sr-x 2 root staff 4096 2006-09-16 19:42 test

    I have also noticed that when I try and upload a file i get the following

    Status: Directory listing successful
    Status: Starting upload of C:\Documents and Settings\brett minnie\Desktop\gw510.jpg
    Command: CWD /test/
    Response: 250 OK. Current directory is /test
    Command: PWD
    Response: 257 "/test" is your current location
    Command: TYPE I
    Response: 200 TYPE is now 8-bit binary
    Command: PASV
    Response: 227 Entering Passive Mode (88,198,5,149,230,225)
    Command: STOR gw510.jpg
    Response: 553-Can't open that file: Permission denied
    Response: 553 Rename/move failure: No such file or directory
    Error: Upload failed
    Status: Retrieving directory listing...
    Command: CWD /test/

    I'm pretty sure its a permissions issue, but need a prod in the right direction to help me out here.

    As stated my config is just as given in the how-to and yeah I'm a bit stumped at the moment

    My Version of pureFTd is this may help as well ^^

    Thanks guys
    Last edited: Sep 17, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure if Pure-FTPd supports symbolic links...

    chown <username>:ftpgroup /home/<username>/test
  3. d3th_n1gG4

    d3th_n1gG4 New Member

    Many thanks that got my upload issues sorted,

    I am led to believe that the lastest version of pureftpd supports symbolic links, maybe i should try compile that, or do you have an alternate software package that you would suggest
  4. falko

    falko Super Moderator ISPConfig Developer

    I haven't tried Pure-FTPd with symbolic links, so I don't know... :eek:

Share This Page