pureftpd and apache2

Discussion in 'Server Operation' started by lefloresg80, Jun 14, 2011.

  1. lefloresg80

    lefloresg80 New Member

    Hello all,

    Newbie question. So I installed pureftpd just as suggested in the tutorial but with nothing else of the perfect server on Ubuntu 11.04. I can do ftp from my machine on filezilla using the localhost but I can't see my computer from the outside. What configurations changes must I make, if any, on my apache .conf file. Thanks!
     
  2. lefloresg80

    lefloresg80 New Member

    OK, so now the port is open and I can connect through filezilla but I'm getting a "Failed to Retrieve Directory List" error. I also get "Status: Server sent passive reply with unroutable address. Using server address instead."

    Example:

    root@box:/etc/pure-ftpd/conf# echo ,21 > Bind
    root@box:/etc/pure-ftpd/conf# echo xx.xx.xx.xx > ForcePassiveIP
    root@box:/etc/pure-ftpd/conf# echo 5000 5050 > PassivePortRange

    Thanks
     
    Last edited: Jun 14, 2011
  3. falko

    falko Super Moderator

    Did you try both active and passive transfers in your FTP client?
     
  4. lefloresg80

    lefloresg80 New Member

    Falko,

    Thank you for your response, I have Filezilla setup to connect on active mode if passive mode fails. From the Filezilla log, it seems it is able to connect but for some reason it can't create the folder list.

    Thanks
     
  5. falko

    falko Super Moderator

    What's the output of
    Code:
    iptables -L
    ?

    Does FTP work from inside your local network, but not from outside? In that case you should also check your router configuration.
     
  6. lefloresg80

    lefloresg80 New Member

    Falko this is my output

    Code:
    root@folders:~# iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination  
    Thanks
     
  7. falko

    falko Super Moderator

    Ok, no firewall - that's ok.

    What about my other question?
     
  8. lefloresg80

    lefloresg80 New Member

    Well at some point it started working, partially, but I think I'm having problems with my static ip, and I don't know if it's conflicting with my hosts file. Now every time I start my computer I have to make changes in the interfaces file in order to get the internet to work. I've tried configuring the static port through the router, with the interfaces file, and both at the same time, but something is amuck. When it does work I can't get passive ports working.

    I just installed 11.04 on both computers at my office, and I have no idea how to go about and create an internal network for file/printer sharing. In the networks place all I see is windows network. So I haven't been able to check through the network. When it does work I end up connecting thrtough the internet on the other computer. I can't simply put 192.168.0.xxx:21 on filezilla and have it work.

    Gonna reboot now and check if I still have to play around with the interfaces file

    Thanks
     
  9. lefloresg80

    lefloresg80 New Member

    It seems that the other computer on my LAN is actually recognizing the internal address. From the outside the I can connect to the server (without passive ports) but then I can't get the folder list.
     
  10. falko

    falko Super Moderator

    So it's working from inside your LAN, but not from the outside? In this case you should check your router settings.
     
  11. lefloresg80

    lefloresg80 New Member

    Falko, I've checked my router settings and they seem to be correct. I have both the 21 port open for FTP and the passive port range open as well. Filezilla actually connects to the server, it just stops on the directory listing command. Could it be the user permissions on the filesystem (fstab) they are 077. So permission for ftpuser and ftpgroup but no access to others.

    Thanks for your help.
     
  12. falko

    falko Super Moderator

    You mean 770, right?
     
  13. lefloresg80

    lefloresg80 New Member

    Hey,

    My umask setting is actually 007. For the time being I need to access it from the server computer itself so I need full access from group now.
     
  14. lefloresg80

    lefloresg80 New Member

    Bump... Falko you there! is 007 for my umask wrong? thanks!
     
  15. falko

    falko Super Moderator

    Usually you should use a umask of 022.
     
  16. lefloresg80

    lefloresg80 New Member

    Changing directions a bit Falko, I think I'm giving up on ftp and going towards the ssh route. It seems more reliable from what I have read and with filezilla I should be able to make it work for windows as well. Only problem is that I added new users but I get a: "Write failed: Broken pipe" error when I try to connect to either users.

    I set them up like you do on your tutorial for the perfect server. I don't want them to have a /home directory, nor access through the splash/greeter page. The ntfs partition has uid=1000 (admin user) and gid=107(ssh). I have also jailed the other 3 users to specific directories. I hope this isn't the problem. I'd appreciate any feedback you might have and that this is at least some what interesting to you! Thanks!
     
  17. lefloresg80

    lefloresg80 New Member

    Falko, did you get my latest post. Hopefully you can help me. Thanks!
     
  18. falko

    falko Super Moderator

    If you want to use SSH/SCP, you must set up a shell account for each user in ISPConfig.
     

Share This Page