PureFTPd 530 Login authentication failed, Critical error: Could not connect to server

Discussion in 'Installation/Configuration' started by labsy, Dec 3, 2019.

  1. labsy

    labsy Member

    Weird,
    similar to this: https://www.howtoforge.com/communit...to-ftp-530-login-authentication-failed.82974/ I faced the same problems all of the sudden:
    FTP client does not authenticate anymore.
    It might be some updates (yesterday) messed this up, but actually 2 days ago it worked, today does not work anymore.
    Ubuntu 18.04 + nginX + pure-ftpd-mysql
    client: FileZilla
    Tried with 2 different usernames, from various locations, different Filezillas...all the same result as of today (AFTER Ubuntu update):
    Code:
     /etc/init.d/pure-ftpd-mysql status
      pure-ftpd-mysql.service
       Loaded: loaded (/etc/init.d/pure-ftpd-mysql; generated)
       Active: active (running) since Tue 2019-12-03 17:17:46 CET; 7min ago
         Docs: man:systemd-sysv-generator(8)
      Process: 1677 ExecStart=/etc/init.d/pure-ftpd-mysql start (code=exited, status=0/SUCCESS)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/pure-ftpd-mysql.service
               └─1768 pure-ftpd (SERVER)
    
    Dec 03 17:19:33 enginex3 pure-ftpd[1941]: pam_unix(pure-ftpd:auth): check pass; user unknown
    Dec 03 17:19:33 enginex3 pure-ftpd[1941]: pam_unix(pure-ftpd:auth): authentication failure; logname= uid=0 euid=0 tty=pure-ftpd ruser=ftuX3ttvgterzbh1 rhost=
    Dec 03 17:19:39 enginex3 pure-ftpd[1941]: ([email protected]) [WARNING] Authentication failed for user [ftuX3ttvgterzbh1]
    Dec 03 17:19:39 enginex3 pure-ftpd[1941]: ([email protected]) [INFO] Logout.
    Dec 03 17:23:06 enginex3 pure-ftpd[2091]: ([email protected]) [INFO] New connection from 84.41.99.5
    Dec 03 17:23:06 enginex3 pure-ftpd[2091]: ([email protected]) [INFO] TLS: Enabled TLSv1.2 with ECDHE-RSA-AES256-GCM-SHA384, 256 secret bits cipher
    Dec 03 17:23:06 enginex3 pure-ftpd[2091]: pam_unix(pure-ftpd:auth): check pass; user unknown
    Dec 03 17:23:06 enginex3 pure-ftpd[2091]: pam_unix(pure-ftpd:auth): authentication failure; logname= uid=0 euid=0 tty=pure-ftpd ruser=ftpu146bu56uzwi2 rhost=
    Dec 03 17:23:12 enginex3 pure-ftpd[2091]: ([email protected]) [WARNING] Authentication failed for user [ftpu146bu56uzwi2]
    Dec 03 17:23:12 enginex3 pure-ftpd[2091]: ([email protected]) [INFO] Logout.
    
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Strange is that it seems to try to authenticate against pam_unix instead of the mysql database. Try to do an ispconfig update with reconfigure services = yes in case a config file got lost.
     
  3. Steini86

    Steini86 Active Member

    Forget this, Problem looks more like the solution by Till ;)
    Maybe your update has overwritten the ftpd config. Try reconfiguring services
    Could be a problem with your servers ssl library. Filezilla is a bit picky about tha and there are a lot of problems like this aroundt:
    https://forum.filezilla-project.org/viewtopic.php?t=51083

    Options:
    a) Use unencrypted FTP (not good, but working)
    b) Use sftp (better solution)
    c) Fix ssl library problem (can be lots of frustrating work)
    d) Try other FTP client which is not so picky
     
  4. labsy

    labsy Member

    Till, thank you, I've tried that, but at no avail :(
    Same error, really looks like pam_unix is in use instead of mysql. This obviously happened with latest updates, as all users were able to FTP few days ago without problems.
    Will check FTP config files more in detail, thout all seem fine at first sight.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    As last resort, uninstall it with --purge. then install it again by following the ftp install chapter from perfect server guide and finally do a ispconfig update with reconfigure services = yes to get the ispconfig specific config back.
     
  6. labsy

    labsy Member

    Ufff, this is becoming painfull.
    Pure-ftpd-mysql on Ubuntu 18.04 has obviously number of issues. I had to run:
    Code:
    openssl dhparam -out /etc/ssl/private/pure-ftpd-dhparams.pem 3072
    in order to get rid of DH-params error, but now I am stuck at [ERROR] TLS renegociation.
    Ah, yes...I completelly did apt-get remove purge autoremove, then reinstalled pure-ftpd and ran ispconfig with reconfigure services=yes. Nothing, still no avail.
     
  7. labsy

    labsy Member

    Solved in some weird manner!

    1.) In server status I noticed, that somehow username got word "default" injected in the middle:
    [WARNING] Authentication failed for user [ftuX3defaultnginx3]
    How was this possiblle, as in Filezilla username was ftuX3nginx3, without "default" in the middle???

    2.) After I sorted out number (1) on CLIENT side, I also had to re-type the password on SERVER side. And voila!....it works!
    The issue with re-saving the password twice is present also in some other ISPConfig servers. I remember many times I simply had to copy the generated password and save it one more time within ISPConfig control panel in order to authenticate properly.

    I am confused and do not even know what was wrong.
     
  8. Steini86

    Steini86 Active Member

    Was some mysql update/change involved? Could be, that the passwords are saved with a different (hash) method .. Had such a problem once, but didn't find the link.
     
  9. labsy

    labsy Member

    I blame extreme clients pressure, dozens of open cases at the same time, so most probably I messed up something at some moment.
    And yes - FileZilla FTP client versions newer than 3.39 do NOT work with Pure-ftpd-mysql with Explicit TLS required on Ubuntu 18.04. that was also on the plate.
     

Share This Page