PureFTP Problem - Won't start, no errors

Discussion in 'Installation/Configuration' started by chr1s_at, Aug 30, 2010.

  1. chr1s_at

    chr1s_at New Member

    Hey guys!

    First let me say that I find ISPConfig totally amazing. Im using it for 5 years when I started my garage-project company.

    My company expanded and I just bought another server on which I'll be using ISPConfig 3

    I set it up by following all steps on the Perfect Setup for Debian Lenny and everything is working..

    well.. except for PureFTP and I have no clue why..


    I installed everything without getting an error, the mysql database is up and running. ISPConfig says that the FTP Server is offline.. Im starting it like this:

    Code:
    debian:~# /etc/init.d/pure-ftpd-mysql start
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -O clf:/var/log/pure-ftpd/transfer.log -H -u 1000 -E -Y 1 -A -B
    lvps83-169-37-161:~#
    
    All log files are empty, no error messages and the port is not in use.. but the server simply isnt running

    Has anyone any clues?
     
  2. damir

    damir New Member

    Make sure that your /etc/default/pure-ftpd-common contains:

    Code:
    STANDALONE_OR_INETD=standalone
    VIRTUALCHROOT=true
    Open /etc/inetd.conf and uncomment following line and restart inetd:

    Code:
    ftp    stream  tcp     nowait  root    /usr/sbin/tcpd /usr/sbin/pure-ftpd-wrapper
    Code:
    /etc/init.d/openbsd-inetd restart

    Last thing is if you are on VPS like OpenVZ than you need to recompile pureftpd without capabilities enabled.

    http://www.faqforge.com/linux/contr...irtual-machines-without-capabilities-enabled/
     
  3. chr1s_at

    chr1s_at New Member


    I have to uncomment this line? cause in the perfect setup it says "comment out"..

    But I just tried to uncomment it and it seems like the server started.. but if I connect it says

    Code:
    Can't exec "/usr/sbin/pure-ftpd": No such file or directory at /usr/sbin/pure-ftpd-wrapper line 174.
    /usr/sbin/pure-ftpd-wrapper: Cannot exec /usr/sbin/pure-ftpd: No such file or directory at /usr/sbin/pure-ftpd-wrapper line 174.
    everything else is set up according to the perfect setup
     
  4. damir

    damir New Member

    Yes you need to remove # in front of the line and than restart the intetd.

    Are you on OpenVZ?
     
  5. till

    till Super Moderator

    1) Which Linux distribution do you use?
    2) Which tutorial did you use to install the server?
     
  6. chr1s_at

    chr1s_at New Member

    I'm using debian Lenny and did everything according to the Perfect Setup Debian 5 + ISPConfig3 tutorial

    I'm not using any virtualization software
     
  7. till

    till Super Moderator

    Thats the same. It means that you shall add a # in fron of the line.

    ok. It seems that pure-ftpd is not fully installed as the pure-ftpd binary is missing please reinstall pure-ftpd with this command:

    Code:
    apt-get install --reinstall pure-ftpd-common pure-ftpd-mysql
     
  8. chr1s_at

    chr1s_at New Member

    Interesting.. it seems like theres a problem while (re)installing..


    Code:
    debian:~# apt-get install --reinstall pure-ftpd-common pure-ftpd-mysql
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    Need to get 0B/173kB of archives.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]?
    Preconfiguring packages ...
    (Reading database ... 37291 files and directories currently installed.)
    Preparing to replace pure-ftpd-common 1.0.21-11.4 (using .../pure-ftpd-common_1.0.21-11.4_all.deb) ...
    Unpacking replacement pure-ftpd-common ...
    Setting up pure-ftpd-common (1.0.21-11.4) ...
    Setting up pure-ftpd-mysql (1.0.21-11.4) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -O clf:/var/log/pure-ftpd/transfer.log -H -u 1000 -E -Y 1 -A -B
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--configure):
     subprocess post-installation script returned error exit status 252
    Errors were encountered while processing:
     pure-ftpd-mysql
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
     
  9. Tone Irene Andersen

    Tone Irene Andersen New Member

    Im having the same issue as the main poster. It doesn't work on debian wheezy. pureftp won't start but is not providing any errors.
     
  10. till

    till Super Moderator

    Which error do you get when you run:

    /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -O clf:/var/log/pure-ftpd/transfer.log -H -u 1000 -E -Y 1 -A -B
     

Share This Page