Pure-ftpd with ISPConfig Issue

Discussion in 'Server Operation' started by feronso, Mar 5, 2014.

  1. feronso

    feronso New Member


    I installed pure-ftpd for ISPConfig from the following tut


    Now i have this error showing.

    Mar  5 12:02:49 ns314913 pure-ftpd: ([email protected]) [INFO] New connection from 182.182.x.x
    Mar  5 12:02:50 ns314913 pure-ftpd: ([email protected]) [INFO] PAM_RHOST enabled. Getting the peer address
    Mar  5 12:02:57 ns314913 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [joed]
    Mar  5 12:02:57 ns314913 pure-ftpd: ([email protected]) [INFO] Logout.

    and CuteFTP pro client showing this logs

    STATUS:>  	[05-Mar-14 4:02:48 PM] Getting listing "/"...
    STATUS:>  	[05-Mar-14 4:02:48 PM] Connecting to FTP server... x.x.x.x:21 (ip = x.x.x.x)...
    STATUS:>  	[05-Mar-14 4:02:48 PM] Socket connected. Waiting for welcome message...
    		[05-Mar-14 4:02:49 PM] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    		220-You are user number 1 of 50 allowed.
    		220-Local time is now 12:02. Server port: 21.
    		220-This is a private system - No anonymous login
    		220-IPv6 connections are also welcome on this server.
    		220 You will be disconnected after 15 minutes of inactivity.
    STATUS:>  	[05-Mar-14 4:02:49 PM] Connected. Authenticating...
    COMMAND:>	[05-Mar-14 4:02:49 PM] USER joed
    		[05-Mar-14 4:02:50 PM] 331 User joed OK. Password required
    COMMAND:>	[05-Mar-14 4:02:50 PM] PASS *****
    		[05-Mar-14 4:02:57 PM] 530 Login authentication failed
    ERROR:>   	[05-Mar-14 4:02:57 PM] Not logged in.
    ERROR:>   	[05-Mar-14 4:02:57 PM] Can't login. Disconnecting...

    I change real IP with x.x.x.x.
    OS: Debian 7 WHezy
    ISPConfig: 3 latest

    Any help appreciated.
    Last edited: Mar 5, 2014
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi Feronso,

    Did you followed word to word with the the guide?

    So I am assuming that you were insatalling debian-5(Lenny perfect Server Guide) from this Link.

    I think you missed the edit part of /etc/inetd.conf.
    Make the changes like this.
    Then restart the service inetd
    Then further follow the FTP with TLS part.

  3. feronso

    feronso New Member

    Hi Srijan,

    Thank you for reply,

    I have not missed any part and word. searching about pure-ftpd-mysql with ISPConfig i found thousands of peoples already have the similar issue with pure-ftpd-mysql and specially with ISPConfig.

    in replacement of this, i have decided to install vsftpd and use default Linux user/group authentication.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats quite funny as there is no common issue with pure-ftpd. I install ispconfig servers daily for our customers and never had a problem and there are more then hundred thousand servers worldwide that use ispconfig with pure-ftpd, so you can rest assured that it works fine. The reason for your problem is most likely a installation problem on your server or something similar, no need to install vsftpd which will not fully work with ispconfig.

    Either your pure-ftpd to connect to pam instead of mysql and pure-ftpd does not seem to run in standalone mode.

    Another option is that you used a wrong username, are you sure that the full username is joed? ISPConfig adds a prefix to the user as usernames have to be unique, so normally the username is something like c1joed or defaultjoed, take a look at the ftp user list in ispconfig, the username is there displayed incl. prefix.

    The text file you used is for Debian 5 only, it does not apply to newer debian versions. Do you really use a debian versin that is so old? If not, then you used a wrong installation guide. The guides for recent debian versions can be found here:

    Last edited: Mar 6, 2014
  5. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    One more thing:
    Try to check if the correct version of pure-ftpd is running with
    ps acux | grep pure
    If it doesn't show "pure-ftpd-mysql" then the non-mysql version is running, which can be easily solved by doing apt-get install pure-ftpd-mysql

Share This Page