pure-ftpd Umask completely ignored...

Discussion in 'Installation/Configuration' started by mousebat, Apr 3, 2014.

  1. mousebat

    mousebat New Member


    I'm using Ubuntu 12.04.4 with the ISPConfig 3 (as per your guide) and for some reason, even though I create the Umask file in /etc/pure-ftpd/conf/ and set the octal values to "000 000" my uploaded files still come through as 644? My ftp client is set to use the permissions from the server so it's not like they are being changed.

    When I issue: 'service pure-ftpd-mysql restart' it shows:

    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -b -E -D -O clf:/var/log/pure-ftpd/transfer.log -8 UTF-8 -U 000:000 -H -A -Y 1 -B

    So the 000:000 umask is being requested.

    Anybody ever try to change the default permissions to 000:000 and had success?

    Many thanks

    MB :confused:
  2. srijan

    srijan New Member HowtoForge Supporter


    Please paste your pure-ftpd.conf file

  3. mousebat

    mousebat New Member

    There is no pure-ftpd.conf file on my box. Unless you count the one from fail2ban?

    This installation uses the pure-ftpd wrapper config where you uses separate config files in the directory /etc/pure-ftpd/conf/.

    The separate files are:

    • AltLog
    • FSCharset
    • PureDB
    • BrokenClientsCompatibility
    • MinUID
    • TLS
    • ChrootEveryone
    • MySQLConfigFile
    • Umask
    • DisplayDotFiles
    • NoAnonymous
    • UnixAuthentication
    • DontResolve
    • PAMAuthentication

    PAMAuthentication is set to yes
    UnixAuthentication is set to no
    ChrootEveryone is set to yes

    Can anyone hazard a guess as to why I can't get the Umask of 000:000 to work?


  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you tried a different umask? So does it just ignore the 000:000 umask or does it ignore all custom umasks?
  5. mousebat

    mousebat New Member

    I've tried a umask 777:777 and it does indeed set new file permissions to 000. I just can't get past 644 (133:133).

    Funnily enough, when I add a directory it takes the 777 permissions as requested. It's just the files that refuse to go past 644!

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then it is not a issue with the way you configured it. most likely some kind of security limitation in pure-ftpd. Maybe someone in the pure-ftpd mailinglist can give you some hints on how to bypass this.

Share This Page