pure-ftpd tls problem

Discussion in 'Installation/Configuration' started by ernie49, Feb 9, 2011.

  1. ernie49

    ernie49 New Member

    Hello,

    I have installed a CentOS 5.5 with latest updates. After this I install pure-ftpd 1.0.29-1.el5.1. I configured it with virtual users and TLS=1 in config. I created a .pem ssl key in /etc/ssl/private with openssl. Pure-ftp starts without problem. FTP works fine but if I try ftpes with Filezilla it hangs. Filezilla is at latest version.

    Filezilla connect log:

    Connecting to xxx.xxx.x.17:21...
    Status: Connection established, waiting for welcome message...
    Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response: 220-You are user number 1 of 50 allowed.
    Response: 220-Local time is now 16:44. Server port: 21.
    Response: 220-This is a private system - No anonymous login
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: AUTH TLS
    Response: 234 AUTH TLS OK.
    Status: Initializing TLS...
    Error: Could not connect to server


    Pure-ftpd log:

    pure-ftpd: (?@xxx.xxx.x.159) [WARNING] Sorry, cleartext sessions are not accepted on this server. Please reconnect using SSL/TLS security mechanisms.

    Did someone have an idea what kind of problem it could be?

    Thanks for help.

    Ernie

    update:

    I tried vsftpd and pro-ftpd. FTP works fine for them but I have the same problem with TLS (ftpes) for both too.
     
    Last edited: Feb 10, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post your PureFTPd configuration file?
     
  3. ernie49

    ernie49 New Member

    Here is my conf file:


    ChrootEveryone yes
    BrokenClientsCompatibility no
    MaxClientsNumber 50
    Daemonize yes
    MaxClientsPerIP 8
    VerboseLog no
    DisplayDotFiles yes
    AnonymousOnly no
    NoAnonymous yes
    SyslogFacility ftp
    DontResolve yes
    MaxIdleTime 5
    PureDB /etc/pure-ftpd/pureftpd.pdb
    PAMAuthentication yes
    LimitRecursion 10000 8
    AnonymousCanCreateDirs no
    MaxLoad 4
    PassivePortRange 30000 50000
    AntiWarez yes
    Umask 133:022
    MinUID 500
    UseFtpUsers no
    AllowUserFXP no
    AllowAnonymousFXP no
    ProhibitDotFilesWrite no
    ProhibitDotFilesRead no
    AutoRename no
    AnonymousCantUpload yes
    AltLog clf:/var/log/pureftpd.log
    MaxDiskUsage 90
    CustomerProof yes
    TLS 1
    IPV4Only yes


    Thank you to help me.

    Kind regards

    Ernie
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I've written a tutorial about how to set up TLS with PureFTPd on CentOS which has not been published yet. This is an excerpt from it which you should try:

     
  5. ernie49

    ernie49 New Member

    Hello,

    1. openssl is installed (latest version from Centos)
    2. TLS = 1
    3: I generated cert files from openssl and certtool (from gnutls) also. I placed them to /etc/ssl/private and /etc/pure-ftpd. I tried one by one.
    4. I did a chmod 600 to the files too. And I restarted pure-ftpd by every change.

    But nothing had change. Always the same problem.

    Kind regards.

    Ernie
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    getenforce
    ?
     
  7. ernie49

    ernie49 New Member

    getenforce= Disabled
    I suppose getenforce=SELinux.

    Firewall (iptables) is also disabled at the moment because it's a futur web and ftp server and I test it on my lan. So there are no firewall problems or passive port problems.

    Thank you that you try to help me.

    Kind regards

    Ernie
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Is this a physical server or a virtual machine?
     
  9. ernie49

    ernie49 New Member

    It's a virtual machine. I runs on VMWare (vSphere) ESX 4.
     
  10. shellscripter

    shellscripter New Member

    cp /etc/ssl/private/pure-ftpd.pem /etc/pki/pure-ftpd/pure-ftpd.pem

    /etc/init.d/pure-ftpd restart
     
    Last edited: Feb 20, 2011
  11. agriz

    agriz New Member

    I am too having problem with pure-ftpd.

    I followed everything properly.

    1) used yum to install pure-ftpd
    2) used yum to install openssl
    3) created new key as mentioned.

    I can list the pure-ftpd users
    But unfortunately, I am getting error
     

Share This Page