Pure-FTPd: Sorry, we were unable to read [.]

Discussion in 'Installation/Configuration' started by maxxer, Feb 21, 2020.

  1. maxxer

    maxxer Member

    We've migrated a ISPConfig 3.1.6 on Ubuntu 10.04 to the latest 3.1.15p2 on Ubuntu18.04 and we're having a weird issue with FTP.
    This customer has a huge directory with >300000 files. On the old server we sorted this out by increasing LimitRecursion, but on the new one we're unable to access this path. We double checked permissions and they're all fine, an ls performed by sudoing to the web user works fine. When trying to list the folder via FTP we get:

    Code:
    ftp> ls
    227 Entering Passive Mode (2,3,9,120,168,21)
    150 Accepted data connection
    226-Sorry, we were unable to read [.]
    226-Options: -a -l
    226 0 matches total
    on the server, after enabling VerboseMode:
    Code:
    Feb 21 17:07:18 ServerWebLinu pure-ftpd: ([email protected]) [DEBUG] Command [pasv] []
    Feb 21 17:07:18 ServerWebLinu pure-ftpd: ([email protected]) [DEBUG] Command [list] []
    Feb 21 17:07:25 ServerWebLinu pure-ftpd: ([email protected]) [DEBUG] Command [cwd] [hugefolder]
    Feb 21 17:07:26 ServerWebLinu pure-ftpd: ([email protected]) [DEBUG] Command [pasv] []
    Feb 21 17:07:26 ServerWebLinu pure-ftpd: ([email protected]) [DEBUG] Command [list] []
    Listing in other paths work fine, it's just that one. I cannot figure out what's wrong and I don't know where to look at, as PureFTPd isn't telling me more. Any idea where I can look in? Thanks
     
  2. Steini86

    Steini86 Active Member

    Never had such a problem. But there are config options you could try: http://www.proftpd.org/docs/howto/ListOptions.html
    For example setting "maxfiles" to 10000 or so and see if it works.
    Looks for me like a special problem of proftpd with many files. Maybe ask directly the proftpd guys
     
  3. maxxer

    maxxer Member

    Thanks but I'm using Pure-FTPd.

    I used this guide.
     
  4. Steini86

    Steini86 Active Member

    Ah, I'm sorry, my fault.
    You could try: ISPC-> system -> server config -> web-> security from high -> medium
    Then change something from that web (for example quota settings) and see if it helps

    I just have understood, you changed Ubuntu Version by quite a bit. The configuration might have changed. In the past it was a single file, now you have to make a file in /etc/pure-ftpd/conf/. Have you done that?
    Code:
    echo '500000 8' > /etc/pure-ftpd/conf/LimitRecursion
    For more options see: https://websiteforstudents.com/setup-pure-ftpd-ubuntu-17-04-17-10/
     
    Last edited: Feb 21, 2020
  5. ahrasis

    ahrasis Well-Known Member

    If you don't mind telling what ftp client are you using to access? Try other client too and see its outcome.
     
  6. maxxer

    maxxer Member

    I tried several clients, from Linux's command line to filezilla and cyberduck
     
  7. maxxer

    maxxer Member

    It was already like this and it's still the same config. I do have 500000 50 as values. Tried temporary removing that setting, no change
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You should consider checking if the developers of the pure-ftpd software have some kind of support forum or mailing list and ask there as your issue seems quite special.
     

Share This Page