pure-ftpd pid file

Discussion in 'Server Operation' started by erosbk, Jun 14, 2011.

  1. erosbk

    erosbk New Member

    Can't find it on /var/run/pureftpd (the folder exists but is empty, pure-ftpd proccess exists and is running perfectly).

    I tried to restart/stop/start the process, but not pid file (I need it for monit).

    Debian 6, pure-ftpd-mysql package installed (perfect setup for debian 6 ispconfig3).

    Could some one help me please?

    thanks
     
  2. falko

    falko Super Moderator

    Did you check the PureFTPd init script in /etc/init.d/? It should contain a reference to the PID file.
     
  3. erosbk

    erosbk New Member

    root@site1:/var/run/pure-ftpd# vdir
    total 0
    root@site1:/var/run/pure-ftpd#

    I have /etc/init.d/pure-ftpd-mysql there, inside, I have this reference (checked before post :p):

    ...
    PIFILE=/var/run/pure-ftpd/pure-ftpd.pid
    ...

    Every start in the script has is reference to PIDFILE

    root@site1:/var# /etc/init.d/pure-ftpd-mysql status
    could not access PID file for pure-ftpd ... failed!

    If I delete the folder /var/run/pure-ftpd, it is creater when pure-ftpd is started. But PID is not created.

    root@site1:/var/run/pure-ftpd# /etc/init.d/pure-ftpd-mysql status
    could not access PID file for pure-ftpd ... failed!

    root@site1:/var/run/pure-ftpd# ps x |grep pure-ftpd
    2283 pts/0 S+ 0:00 grep pure-ftpd
    21567 ? Ss 0:00 pure-ftpd (SERVER)

    This smells like a bug...
     
  4. erosbk

    erosbk New Member

    When start pure-ftpd, I have no reference -g to pid file (it is hardwire, I think it should appear)

    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -E -H -Y 1 -p 29799:29999 -c 100 -8 UTF-8 -I 10 -O clf:/var/log/pure-ftpd/transfer.log -L 5000:500 -u 1000 -T 64 -b -A -k 95 -4 -D -B
     
  5. falko

    falko Super Moderator

    Can you try this and restart PureFTPd (please check if /etc/pure-ftpd/conf/PidFile exists already, and if so, make a backup of it before)?

    Code:
    echo "/var/run/pure-ftpd/pure-ftpd.pid" > /etc/pure-ftpd/conf/PidFile
     
  6. erosbk

    erosbk New Member

    I tried, but pureftpd will not start again (I can't remember the error, but PidFile was deprecated because right now it is hardwire. I will repeat and post here the error)
     
  7. jluros

    jluros New Member

    That solution doesn't work. I'm also trying to get pure-ftpd to use the PIDFILE directive in the init.d script, but for some reason, either it's not getting passed to /usr/sbin/pure-ftpd-wrapper, or /usr/sbin/pure-ftpd-wrapper isn't accepting PIDFILE as an argument.
     

Share This Page