Pure Ftpd Passive Ports setup

Discussion in 'Server Operation' started by alleks, May 25, 2011.

  1. alleks

    alleks Member

    Hi folks, I need your help to setup a range of passive ports for the pure-ftpd server. All the documentation I have read they were talking of typing a line in /etc/pure-ftpd.conf but I don't have that file...

    I have a pure-ftpd folder in etc containing some folders

    ls -al /etc/pure-ftpd
    Code:
    drwxr-xr-x   2 root root 4096 May 18 08:01 auth
    drwxr-xr-x   2 root root 4096 May 18 08:37 conf
    drwxr-xr-x   2 root root 4096 May 18 08:37 db
    -rw-r--r--   1 root root  230 May 18 07:59 pureftpd-dir-aliases
    
    any help would be very appreciated.
     
  2. erosbk

    erosbk New Member

    Create a file in /etc/pure-ftpd/conf/PassivePortRange, inside, just write the port range separated with a space.

    echo "29799 29899" > /etc/pure-ftpd/conf/PassivePortRange

    (for max 50 connected clients)

    pure-ftpd uses files in conf dir as parameters. Be carefull setting your ports, they must NOT be used by the kernel.

    You must have 2 ports for every client (max 100 clients, you need 200 ports).
    If you need more or less than 50 default clients allowed, you must:

    echo "50" > /etc/pure-ftpd/conf/MaxClientsNumber

    Replace 50 with the number you want to allow...

    Remember to restart pureftpd.
     
    todx and dzint like this.
  3. alleks

    alleks Member

    erosbk, I didn't got to say thanks. It was very helpful your post.
     
  4. erosbk

    erosbk New Member

    np, you are welcome xD
     
  5. todx

    todx Member

    Solved my problem, thanks!
    Note: I also had to open up those ports in ISPConfig3 under "Firewall" I added ",29799:29899" at the end.
     
  6. harkman

    harkman New Member HowtoForge Supporter

    This makes me wonder. My server was running without this settings until last week. Since then nobody was able to login with TLS encryption active. I really would like to know why I suddenly need to configure the PASV port range and open it in the firewall.
     

Share This Page