Pure-ftpd Passive IP address and port range

Discussion in 'ISPConfig 3 Priority Support' started by BobGeorge, Aug 15, 2017.

  1. BobGeorge

    BobGeorge Member HowtoForge Supporter

    I've added a file "ForcePassiveIP" with an external IP address to the /etc/pure-ftpd/conf directory and also a file "PassivePortRange" to the same directory with two numbers to define the port range.

    I've restarted the "pure-ftpd-mysql" service, but yet, when I attempt to connect via FTP (and examine what's coming into the server via "tcpdump"), it's complaining that the IP address is unreachable and the packets coming in are not within the passive port range I specified.

    Pure-ftpd has a strange configuration style - lots of little one-line files - so I'm not sure if just creating the files in the "conf" directory is good enough, or must I specify to it somehow that I want it to use these new settings via another setting?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. BobGeorge

    BobGeorge Member HowtoForge Supporter

    I rebooted the cluster and it just worked.

    I must have made a wrong setting somewhere, but goodness knows what it was. A cold boot, though, is a good way to clear out the pipes. :)
     

Share This Page