pure-ftpd-mysql passwords hash not working

Discussion in 'General' started by Thesee, Nov 20, 2019.

  1. Thesee

    Thesee New Member

    Hi,
    i'have the same problem describe here: https://www.howtoforge.com/community/threads/pure-ftpd-mysql-passwords-weird.83009/
    I just created a new ftp account and i cannot login in. Checking the database i can see that old password (that actually works) are stored as $1$1st0uOpE$kkMREglGqbIk7rU1rbQi1/ and the new as $6$rounds=5000$8eb823e3a2086834$1fZ8PuDEVn.z2uApey0Dz2BC2c.6g8e1/JPDjegF.ltVVjTmjCmKimsJ.GHTzQmhBFlwHHD/EPqUNCq/MfVhI.

    Someone can drive me in the right direction to do things work again? (the tip ont the thread linked to create password with mkpasswd --method=md5 --stdin does not work)

    Thank you
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The new password hash is fine, it's just a newer encryption mechanism which is supported by current pure-ftpd versions. Which Linux distribution and pure-ftpd version are you using?

    This indicates that your problem is not the password has then. Check the pure-ftpd log file for errors. Or you might have accidentially overwritten pure-ftpd config files while installing updates and pure-ftpd is not able to connect to mysql anymore.
     
  3. Thesee

    Thesee New Member

    Hi Till,
    my linux distribution is : Ubuntu 18.04.2 LTS
    I can confirm that pure-ftpd is working with mysql because it works with ftp account stored with old hash
    pure-ftpd version --> v1.0.46
    ispconfig version: 3.1.15p2
    Any advice?
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Check the pure-ftpd log file for errors.
     
  5. Thesee

    Thesee New Member

    Yep, checked but nothing useful
    Code:
    systemd[1]: Starting pure-ftpd-mysql.service...
    pure-ftpd-mysql[39317]: Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -Y 1 -8 UTF-8 -O clf:/var/log/pure-ftpd/transfer.log -A -H -b -p 6500:6600 -u 1000 -D -E -J HIGH -B
    systemd[1]: Started pure-ftpd-mysql.service.
    pure-ftpd: ([email protected]) [INFO] New connection from IP
    pure-ftpd: ([email protected]) [INFO] TLS: Enabled TLSv1.3 with TLS_AES_256_GCM_SHA384, 256 secret bits cipher
    pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [myuserftp]
    pure-ftpd: ([email protected]) [INFO] Logout.
    
    Enabling Verbose log does not log any other usefull information.

    Same action with old stored password account:
    Code:
    pure-ftpd: ([email protected]) [INFO] New connection from IP
    pure-ftpd: ([email protected]) [INFO] TLS: Enabled TLSv1.3 with TLS_AES_256_GCM_SHA384, 256 secret bits cipher
    pure-ftpd: ([email protected]) [INFO] myolduserftp is now logged in
    pure-ftpd: ([email protected]) [INFO] TLS: Enabled TLSv1.3 with TLS_AES_256_GCM_SHA384, 256 secret bits cipher
    
     
  6. Thesee

    Thesee New Member

    Nevermind... just updated an old account and the password is in the new format and it works, so probably is a problem related to the account.
     

Share This Page