Pure-ftpd Login Problem

Discussion in 'General' started by AsDsL, Oct 26, 2009.

  1. AsDsL

    AsDsL New Member

    Hi,
    After upgrade to ISPConfig 3.0.1.6, I cant login into ftp server.

    Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
    Error: Could not connect to server

    How may I fix it/
    Thanks1
    tony
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which Linux distribution?
     
  3. AsDsL

    AsDsL New Member

    Ubuntu 9.04
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? Any errors in your logs?
     
  5. ilja

    ilja New Member

    i have the same problem,

    netstat -tap gives

    ================
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:35362 *:* LISTEN 2759/rpc.statd
    tcp 0 0 localhost:10024 *:* LISTEN 2927/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 3570/master
    tcp 0 0 *:mysql *:* LISTEN 2991/mysqld
    tcp 0 0 localhost:spamd *:* LISTEN 3062/spamd.pid
    tcp 0 0 *:sunrpc *:* LISTEN 2748/portmap
    tcp 0 0 10.150.1.2:domain *:* LISTEN 3498/mydns
    tcp 0 0 localhost:domain *:* LISTEN 3498/mydns
    tcp 0 0 localhost:822 *:* LISTEN 3614/famd
    tcp 0 0 *:ssh *:* LISTEN 2898/sshd
    tcp 0 0 *:smtp *:* LISTEN 3570/master
    tcp 0 0 10.150.1.2:43993 villa.debian.org:www TIME_WAIT -
    tcp 0 0 localhost:53764 localhost:www TIME_WAIT -
    tcp 0 0 10.150.1.2:56977 unassigned-92.colo.:www TIME_WAIT -
    tcp 0 0 localhost:59445 localhost:domain TIME_WAIT -
    tcp 0 0 10.150.1.2:34168 kassia4.snt.utwente:www TIME_WAIT -
    tcp 55 0 localhost:39470 localhost:10025 CLOSE_WAIT 3434/amavisd (ch1-a
    tcp 0 288 10.150.1.2:ssh 10.150.6.10:51168 ESTABLISHED 25070/sshd: ilja [p
    tcp 0 0 10.150.1.2:53838 ftp.belnet.be:www TIME_WAIT -
    tcp6 0 0 [::]:imaps [::]:* LISTEN 3470/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 3493/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 3481/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 3458/couriertcpd
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 3675/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 3675/apache2
    tcp6 0 0 localhost:domain [::]:* LISTEN 3498/mydns
    tcp6 0 0 [::]:ssh [::]:* LISTEN 2898/sshd
    tcp6 0 0 [::]:https [::]:* LISTEN 3675/apache2
    ==========


    So it's not listening on port 21.
    pure-ftpd-control start doesn't do anything. There's no obvious errors in any logs, no mention of pureftp in syslog or messages...
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Is this a vserver?
     
  7. ilja

    ilja New Member

    yes it is, debian lenny
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I guess you installed debian updates too and not just a ispconfig update. Your problem is that the debian update installed a pure-ftpd version with capabilities enabled and this is incompatible with the vserver solution (openvz or virtuozzo) that is used on your server.

    Please recompile pure-ftpd as you did initially as you installed the server.
     
  9. AsDsL

    AsDsL New Member

    Hi till,
    I reinstalled as tutorial says again and now I have this problem:

    Status: Connecting to 12.43.x.x:21...
    Status: Connection established, waiting for welcome message...
    Error: Connection timed out
    Error: Could not connect to server
    Status: Waiting to retry...

    Thanks,
    tony
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please enable debugging in pure-ftpd and post the lines from the log file.
     
  11. AsDsL

    AsDsL New Member

    Nov 25 23:31:57 ns1 pure-ftpd: (?@?) [ERROR] Sorry, invalid address given

    Thanks,
    Tony
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  13. AsDsL

    AsDsL New Member

    Fixed,
    Thanks,
    tony
     
  14. kidd

    kidd New Member

    I have the same problem as the first post.

    But I don't understand what you mean with "Please recompile pure-ftpd as you did initially as you installed the server."

    I'm using Ubuntu 9.10.

    Could my problem be the same?
     
  15. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please make always a new thread as in almost all cases, the reason for your problem is not the same. And include a detailed error description and the error messages from the mail log file in your new thread.
     

Share This Page