pure ftpd issue

Discussion in 'HOWTO-Related Questions' started by kwickcut, Apr 16, 2015.

  1. kwickcut

    kwickcut Member HowtoForge Supporter

    i am running ubuntu 10.04.4 lts i used the perfect server setup some time ago and pure ftpd was the default ftp server..

    a few days ago i ran some updates and i am not sure what i did but somehow i installed proftpd.. when i noticed this issue i uninstalled proftpd and reinstalled pureftpd.. i then configured it using the original install how to.. this issue i am having is below... i am lost and have tried everything i could and i am out of things to try..



    Code:
    Status:   Resolving address of www.mysite.com
    Status:   Connecting to XX.XXX.XX.XXX:21...
    Status:   Connection established, waiting for welcome message...
    Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:   220-You are user number 1 of 50 allowed.
    Response:   220-Local time is now 18:27. Server port: 21.
    Response:   220-IPv6 connections are also welcome on this server.
    Response:   220 You will be disconnected after 15 minutes of inactivity.
    Command:   AUTH TLS
    Response:   234 AUTH TLS OK.
    Status:   Initializing TLS...
    Status:   Verifying certificate...
    Command:   USER username
    Status:   TLS/SSL connection established.
    Response:   331 User username OK. Password required
    Command:   PASS ********
    Response:   530 Login authentication failed
    Error:   Critical error
    Error:   Could not connect to server
    
    forgot to add i also run this how to for making the pureftpd tls connection only
    https://www.howtoforge.com/how-to-configure-pureftpd-to-accept-tls-sessions-on-ubuntu-10.10

    thanks for any input


    kwick
     
    Last edited: Apr 16, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you install pure-ftpd or pure-ftpd-mysql ? The mysql version is needed to authenticate against the ispconfig mysql database.
     
  3. kwickcut

    kwickcut Member HowtoForge Supporter

    i installed pure-ftpd-mysql when i first installed i received the error
    Code:
    chmod: cannot access `/etc/pure-ftpd/db/mysql.conf': No such file or directory
    dpkg: error processing pure-ftpd-mysql (--configure):
    so i created the file mysql.conf and reinstalled pure-ftpd-mysql

    when i check the file it is empty
    Code:
    vi etc/pure-ftpd/db/mysql.conf
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This file gets created by ispconfig during ispconfig installation, so dont create it manually. If it is missing, run a ispconfig update and choose to reconfigure services to create it.
     
  5. kwickcut

    kwickcut Member HowtoForge Supporter

    ok i have run the reconfigure

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    and i am still getting the same thing

    Code:
    Status:    Resolving address of www.server.com
    Status:    Connecting to XX.XXX.XX.XXX:21...
    Status:    Connection established, waiting for welcome message...
    Response:    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:    220-You are user number 1 of 50 allowed.
    Response:    220-Local time is now 21:09. Server port: 21.
    Response:    220-IPv6 connections are also welcome on this server.
    Response:    220 You will be disconnected after 15 minutes of inactivity.
    Command:    AUTH TLS
    Response:    234 AUTH TLS OK.
    Status:    Initializing TLS...
    Status:    Verifying certificate...
    Command:    USER username
    Status:    TLS/SSL connection established.
    Response:    331 User username OK. Password required
    Command:    PASS ********
    Response:    530 Login authentication failed
    Error:    Critical error
    Error:    Could not connect to server
    now i tried adding a new ftp account and i am getting the same results... now i did notice something that i have not seen before when i click on add new ftp user this is how the list of sites looks

    Code:
    mysite.com :: server1.myserver.com
    i thought i should look like this

    Code:
    mysite.com : server1.myserver.com
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. kwickcut

    kwickcut Member HowtoForge Supporter

    the user names do not have any prefix...

    ok this is what i have in the sys.log after trying to log into the ftp with 2 different accounts

    Code:
    Apr 20 17:35:01 servers pure-ftpd: ([email protected]) [INFO] New connection from localhost
    
    Apr 20 17:35:01 servers pure-ftpd: ([email protected]) [INFO] Logout.
    
    Apr 20 17:35:01 servers pop3d: Connection, ip=[::1]
    
    Apr 20 17:35:01 servers imapd: Connection, ip=[::1]
    
    Apr 20 17:35:01 servers pop3d: Disconnected, ip=[::1]
    
    Apr 20 17:35:01 servers imapd: Disconnected, ip=[::1], time=0
    
    Apr 20 17:35:01 servers postfix/smtpd[22584]: warning: ::1: address not listed for hostname localhost
    
    Apr 20 17:35:01 servers postfix/smtpd[22584]: connect from unknown[::1]
    
    Apr 20 17:35:01 servers postfix/smtpd[22584]: lost connection after CONNECT from unknown[::1]
    
    Apr 20 17:35:01 servers postfix/smtpd[22584]: disconnect from unknown[::1]
    
    Apr 20 17:35:23 servers pure-ftpd: ([email protected]) [INFO] New connection from 155.sub-70-215-78.myvzw.com
    
    Apr 20 17:35:23 servers pure-ftpd: ([email protected]) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with DHE-RSA-AES128-SHA, 128 secret bits cipher
    
    Apr 20 17:35:25 servers pure-ftpd: ([email protected]) [INFO] PAM_RHOST enabled. Getting the peer address
    
    Apr 20 17:35:32 servers pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [mikemike]
    
    Apr 20 17:35:32 servers pure-ftpd: ([email protected]) [INFO] Logout.
    
    Apr 20 17:36:01 servers CRON[22624]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    
    Apr 20 17:37:01 servers CRON[22635]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    
    Apr 20 17:38:01 servers CRON[22646]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    
    Apr 20 17:39:01 servers CRON[22668]: (root) CMD (  [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -type f -cmin +$(/usr/lib/php5/maxlifetime) -delete)
    
    Apr 20 17:39:01 servers CRON[22669]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    
    Apr 20 17:39:04 servers pure-ftpd: ([email protected]) [INFO] New connection from 155.sub-70-215-78.myvzw.com
    
    Apr 20 17:39:04 servers pure-ftpd: ([email protected]) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with DHE-RSA-AES128-SHA, 128 secret bits cipher
    
    Apr 20 17:39:05 servers pure-ftpd: ([email protected]) [INFO] PAM_RHOST enabled. Getting the peer address
    
    Apr 20 17:39:13 servers pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [yoyo]
    
    Apr 20 17:39:14 servers pure-ftpd: ([email protected]) [INFO] Logout.
    
    
     
  8. hi i have the same issue .... however it seems that pure ftp is not queried the database , all service is start normal ... appreciate any help

    this is for a certain user

    Jun 4 14:37:32 web2 pure-ftpd: ([email protected]) [INFO] New connection from x.x.x.x
    Jun 4 14:37:32 web2 pure-ftpd: ([email protected]) [DEBUG] Command [user] [user]
    Jun 4 14:37:32 web2 pure-ftpd: ([email protected]) [DEBUG] Command [pass] [<*>]
    Jun 4 14:37:32 web2 pure-ftpd: ([email protected]) [INFO] PAM_RHOST enabled. Getting the peer address
    Jun 4 14:37:42 web2 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [raeworx]
    Jun 4 14:37:42 web2 pure-ftpd: ([email protected]) [INFO] Logout.
     
  9. ahrasis

    ahrasis Well-Known Member

    Firstly, it is best not to revive any old threads though they may seem similar unless it very very necessary.

    Secondly, we need details of your server setup especialy your pure-ftpd service setup.

    Do note unless you are using RHEL or Centos setup which install pure-ftpd, pure-ftpd-mysql is the required install in Debian or Ubuntu setup for the same.
     

Share This Page