pure-ftpd and ssl/tls

Discussion in 'Server Operation' started by robertlouwen, Apr 16, 2010.

  1. robertlouwen

    robertlouwen New Member

    Hello all,

    I want my ftp connection more secure, so I edited /etc/pure-ftpd/pure-ftpd.conf and un-commented TLS and gave it value 2.
    After that I created the key
    [FONT=Courier New]openssl req -x509 -nodes -newkey rsa:1024 -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem[/FONT]
    and chmod 600 pure-ftpd.pem.

    Now I start Filezilla and change the log in methode from SFTP to FTPES and log in.

    Filezilla ask me for the password and ask me to accept the certifiacate, to end with:
    • GnuTLS Error -53: error in the push function
    • Connection timed out
    • Failed to retrieve directory listing
    Information given by Filezilla in pure-ftpd.txt
    Info from /var/log/messages in varlogmessages.txt

    Help would be apreciated.

    Attached Files:

  2. robertlouwen

    robertlouwen New Member

    Anyone ???
  3. RogueCoder

    RogueCoder New Member

    I had this issue just today. I'll assume you're using iptables to filter network traffic. It won't work with FTP/SSL, because it uses a wide port range and the ftp module that dynamically changes firewall rules can't see the FTP commands since they are encrypted. You must disable iptables or open all ports > 1024

Share This Page