pure-ftpd - 530 Permission Denied

Discussion in 'General' started by sellotape, Nov 22, 2010.

  1. sellotape

    sellotape New Member

    Hi there.

    I'm using ISPConfig 3 on CentOS 5.5
    I followed HowToForge's guide for the perfect server.

    I've created an FTP user for my website, however when I attempt to connect using an FTP client such as FileZilla or even my web browser I am getting errors!

    Here's what FileZilla says...

    Code:
    Status:	Resolving address of ftp.<url>
    Status:	Connecting to <myIp>:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220 Inactivity timer = 120 seconds. Use 'site idle <secs>' to change.
    Command:	USER <username>
    Response:	331  Password required.
    Command:	PASS *************
    Response:	530 Permission denied
    Error:	Critical error
    Error:	Could not connect to server
    The username and password I am using are the ones I have setup in ISPConfig.

    It seems to be connecting, just not recognising.
    Very odd!

    Any ideas?

    As always, your help is always greatly appreciated.
    Thanks


    Ash
     
  2. till

    till Super Moderator

    Please post the output of the commands:

    netstat -tap

    and

    iptables -L
     
  3. sellotape

    sellotape New Member

    Hi there.

    netstat -tap
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 localhost.localdomain:2208  *:*                         LISTEN      2275/hpiod
    tcp        0      0 *:imaps                     *:*                         LISTEN      2445/dovecot
    tcp        0      0 *:pop3s                     *:*                         LISTEN      2445/dovecot
    tcp        0      0 *:cbtd                      *:*                         LISTEN      2234/pipslited
    tcp        0      0 localhost.localdomain:10024 *:*                         LISTEN      2491/amavisd (maste
    tcp        0      0 localhost.localdomain:10025 *:*                         LISTEN      2548/master
    tcp        0      0 *:mysql                     *:*                         LISTEN      2416/mysqld
    tcp        0      0 *:netbios-ssn               *:*                         LISTEN      2649/smbd
    tcp        0      0 *:907                       *:*                         LISTEN      1997/rpc.statd
    tcp        0      0 *:pop3                      *:*                         LISTEN      2445/dovecot
    tcp        0      0 localhost.local:dyna-access *:*                         LISTEN      2328/clamd
    tcp        0      0 *:imap                      *:*                         LISTEN      2445/dovecot
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      1961/portmap
    tcp        0      0 *:ftp                       *:*                         LISTEN      3896/pure-ftpd (SER
    tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      1904/named
    tcp        0      0 *:ipp                       *:*                         LISTEN      2310/cupsd
    tcp        0      0 *:smtp                      *:*                         LISTEN      2548/master
    tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      1904/named
    tcp        0      0 *:microsoft-ds              *:*                         LISTEN      2649/smbd
    tcp        0      0 localhost.localdomain:2207  *:*                         LISTEN      2280/python
    tcp        0      0 localhost.localdomain:60441 localhost.localdomain:mysql ESTABLISHED 2671/amavisd (ch17-
    tcp        0      0 server.cube.com:imap        bda-178-239-84-96.bis:39103 ESTABLISHED 2039/imap
    tcp        0      0 localhost.localdomain:58935 localhost.localdomain:mysql ESTABLISHED 2672/amavisd (ch18-
    tcp        0      0 server.cube.co:microsoft-ds 192.168.1.66:49160          ESTABLISHED 5539/smbd
    tcp        0      0 localhost.localdomain:mysql localhost.localdomain:60441 ESTABLISHED 2416/mysqld
    tcp        0      0 localhost.localdomain:mysql localhost.localdomain:58935 ESTABLISHED 2416/mysqld
    tcp        0      0 *:imaps                     *:*                         LISTEN      2445/dovecot
    tcp        0      0 *:pop3s                     *:*                         LISTEN      2445/dovecot
    tcp        0      0 *:pop3                      *:*                         LISTEN      2445/dovecot
    tcp        0      0 *:imap                      *:*                         LISTEN      2445/dovecot
    tcp        0      0 *:webcache                  *:*                         LISTEN      2578/httpd
    tcp        0      0 *:http                      *:*                         LISTEN      2578/httpd
    tcp        0      0 *:tproxy                    *:*                         LISTEN      2578/httpd
    tcp        0      0 *:ftp                       *:*                         LISTEN      3896/pure-ftpd (SER
    tcp        0      0 localhost6.localdoma:domain *:*                         LISTEN      1904/named
    tcp        0      0 *:ssh                       *:*                         LISTEN      2297/sshd
    tcp        0      0 *:ipp                       *:*                         LISTEN      2310/cupsd
    tcp        0      0 localhost6.localdomain:rndc *:*                         LISTEN      1904/named
    tcp        0      0 *:https                     *:*                         LISTEN      2578/httpd
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55855 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55854 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55853 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55861 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55860 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55859 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55858 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55857 TIME_WAIT   -
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55856 TIME_WAIT   -
    tcp        0    296 server.cube.com:ssh         ::ffff:192.168.1.66:62587   ESTABLISHED 17615/0
    tcp        0      0 server.cube.com:http        188-223-147-199.zone1:55865 TIME_WAIT   -
    

    And iptables -L
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Thanks


    Ash
     
  4. till

    till Super Moderator

    Looks fine so far. Are you sure that you used the correct username incl. the prefix as it is listed in the ftp user list? So a username normally is something like c0user and not just uder or it has the client name as prefix.
     
  5. sellotape

    sellotape New Member

    Hi there.

    I've double checked everything and all is okay and I am still getting the 530 error.
    I've been doing some research and it's just a hunch - but could it be because virtual users in pureftpd is not enabled?

    If so, how could I enable it please?

    Thanks


    Ash
     
    Last edited: Nov 22, 2010
  6. sellotape

    sellotape New Member

    Just an update.

    I've checked my ispconfig database and can confirm that the details I enter when creating an FTP user are being entered into the correct table in the database.

    I am literally stumped as to why it will not work.

    I can connect via SFTP to my server direct on my local network so pure-ftpd must be working. I simply cannot get my head around why it won't work for me when I try and connect to ftp.<domain>.com.

    Thanks


    Ash
     
  7. till

    till Super Moderator

    sftp is provided by sshd and not pure-ftpd.

    and you are sure that you created a dns record for this subdomain and that it points to the correct server? Try to use the server IP instead of that ubdomain to connect to the system.
     
  8. sellotape

    sellotape New Member

    I can be thick sometimes...

    It generally helps when port 21 is allowed through your router's firewall.
    It's took me two days to figure that out... (bad times)

    Thank you for all your help Till.

    So... if anyone else is having this problem.
    Make sure Port 21 is not being blocked by your router!
     
    Last edited: Nov 23, 2010
  9. alex_popa_81

    alex_popa_81 New Member

    Hello. My port is forwarded correctly from the router.
    My SO and apt's:

    Debian Squeeze 64 bit
    pure-ftpd pure-ftpd-common
    I'm not using ISPConfig, it's just another type of panel. Anyway, the accounts are created correctly from the panel, Internet Explorer wants to connect to the folder, asks me about user and pass, but after that, just keep telling "Page cannot be displayed"

    Another thing, when trying to see if the service is up, /etc/init.d/pure-ftpd status returns an error saying no PID file is found......
    But ps aux returns pure-ftpd server with pid 1162.
    Furthermore, netstat -tap returns pure-ftpd server up and I'm starting to lose my mind in here :) Just a little..... someone please help.

    Tip: I found on another forum a discussion about pure-ftpd-mysql and Debian Squeeze not beeing able to create connections and returning 530 Error... this would be really unfortunate, because I MUST use this version of OS.
     
  10. till

    till Super Moderator

    Dont worry, the information that you found in the other forum is completely wrong. pure-ftp works perfectly on debian 6. I still run a lot of servers with debian 6 and pure-ftpd successfully.

    Its a bit complicated to help you as you dont use ispconfig and I dont know yours etup in detail. You should check that you run pure-ftpd in standalone mode, nit in inetd mode. Check chapter 13 here: http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-dovecot-ispconfig-3-p4
     

Share This Page