Pure-ftpd 421 Out of memory

Discussion in 'Server Operation' started by F4lcon, Jun 24, 2018.

  1. F4lcon

    F4lcon New Member

    Hi, I have an issue with Debian Stretch and Pure-fptd installed on a server with 64GB of ram.
    I've set LimitRecursion to handle 100k files in one directory, but when ftp client (FileZilla and others) is trying to display over 60k files it stops with 421: Out of memory message. I know it's not ideal to handle so many files in one directory but just need to fix it somehow.
    Is there any way how to allocate more memory to Pure-ftpd with soft limits or something?
    Thanks for any help.
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    What does the following show:
    Code:
    cat /proc/sys/fs/file-max
    ulimit -Hn
    
    make sure root can handle the amount of files, it can be limited, pure-ftp main runs as root.
    If that's ok, maybe add a /etc/security/limits.d/user_name file defining filelimits.
     
  3. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    you also could check
    /etc/systemd/system.conf and /etc/systemd/user.conf
    setting
    DefaultLimitNOFILE=20000...

    Haven't looked wether it could be installed like the other services with their own directory and specific limits.conf, since pure-ftp does not have this by default on stretch. Hadn't any issue regarding this so far.
     

Share This Page