Pure-ftp virtual users - authentication fails

Discussion in 'Server Operation' started by jbenezech, Aug 7, 2013.

  1. jbenezech

    jbenezech New Member

    I have been unable to get the virtual users working on Debian Squeeze. Authentication fails for non system users (system users login fine).
    I've tried to set VerboseLog on but don't get anything in the log other than

    Aug 6 09:20:34 vps pure-ftpd: ([email protected]) [INFO] New connection from xxx.xxx.xxx.xx
    Aug 6 09:20:34 vps pure-ftpd: ([email protected]) [INFO] PAM_RHOST enabled. Getting the peer address
    Aug 6 09:20:39 vps pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [myvirtualuser]

    I've searched several threads and found something related to pure-ftp not being pure-ftp-mysql. Do I have to install pure-ftp-mysql to get virtual users working ?

  2. tanius

    tanius New Member


    Yes, you have to install package pure-ftpd-mysql instead of pure-ftpd (using Debian / Ubuntu package names here) in order to be able to use virtual users. I just had the very same problem, and this fixed it for me immediately:

    apt-get install pure-ftpd-mysql

    More information about other possible reasons etc. can be found in the blog post that I just wrote about it: "How to fix '530 Login authentication failed' for ISPConfig FTP logins?".

Share This Page