Pure-FTP Timeout on Connect

Discussion in 'Installation/Configuration' started by cjsdfw, May 1, 2020.

  1. cjsdfw

    cjsdfw Member

    Hi,
    I just defined my first FTP account in ISPConfig3 but when I try to connect it timesout reading the directory.

    Here is the syslog and connecting client messages:
    Code:
    tail -f  /var/log/syslog |grep pure-ftpd: --line-buffered
    
    May  1 17:48:33 web pure-ftpd: ([email protected]?) [DEBUG] Couldn't load the DH parameters file /etc/ssl/private/pure-ftpd-dhparams.pem
    May  1 17:49:32 web pure-ftpd: ([email protected]) [INFO] New connection from 1.2.3.4
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [auth] [TLS]
    May  1 17:49:32 web pure-ftpd: ([email protected]) [INFO] TLS: Enabled TLSv1.2 with ECDHE-RSA-AES256-GCM-SHA384, 256 secret bits cipher
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [user] [user_name]
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [pass] [<*>]
    May  1 17:49:32 web pure-ftpd: ([email protected]) [INFO] user_name is now logged in
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [syst] []
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [feat] []
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [opts] [UTF8 ON]
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [pbsz] [0]
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [prot] [P]
    May  1 17:49:32 web pure-ftpd: ([email protected]) [DEBUG] Command [pwd] []
    May  1 17:49:33 web pure-ftpd: ([email protected]) [DEBUG] Command [type] [A]
    May  1 17:49:33 web pure-ftpd: ([email protected]) [DEBUG] Command [pasv] []
    May  1 17:49:33 web pure-ftpd: ([email protected]) [DEBUG] Command [mlsd] []
    
    
    Error From Connecting Client:
    
    Timeout detected. (data connection)
    Could not retrieve directory listing
    Error listing directory '/'.
    
    I tried connecting with several FTP Clients but the connections times out. It looks like its connecting fine from the above message.
    I found a posting (post#4) suggesting the following action but I am hesitant since I do not know what it does:
    Any suggestions?
     
  2. cjsdfw

    cjsdfw Member

    Ah...
    If I disable the firewall I get connected. So it seems is firewall related. I read something about "Passive Connections" so I will research the subject and give it a try.
     
  3. cjsdfw

    cjsdfw Member

    Fixed! Here is what I did after google help :)
    To configure a Passive Connection in Pure-FTP:
    I was able to connect!
    Hope this helps others too.
     
    Last edited: May 4, 2020
    Taleman likes this.
  4. nhybgtvfr

    nhybgtvfr Active Member

    i'm assuming this is just a typo and not a copy and paste from your firewall rules. but alerting here just in case, you may have a *lot* more ports open that you intended.
     
  5. cjsdfw

    cjsdfw Member

    Hi nhybgtvfr,
    Yes is a typo: Thanks for noticing. I will see if I can edit the post. I opened 100 ports!
     

Share This Page