Pure-FTP Suddenly Stopped Working - IPSConfig.

Discussion in 'Installation/Configuration' started by strang3r, Dec 4, 2014.

  1. strang3r

    strang3r Member

    Today PureFTP suddenly stopped working in ISPConfig. :eek:

    I got this error one service offline (FTP Offline) in ISPConfig Overview. Also not able to get access with any ftp user by ftp client.

    In Firewall port 21 is open.

    This what I get if I do service restart.

    Code:
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -E -A -Y 1 -D -O clf:/var/log/pure-ftpd/transfer.log -8 UTF-8 -b -u 1000 -H -B
    
    This is my netstat -tap . There is no ftp port listening.....?

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      3712/master     
    tcp        0      0 *:mysql                 *:*                     LISTEN      2885/mysqld     
    tcp        0      0 *:submission            *:*                     LISTEN      3712/master     
    tcp        0      0 localhost.localdo:11211 *:*                     LISTEN      2507/memcached  
    tcp        0      0 *:pop3                  *:*                     LISTEN      3535/dovecot    
    tcp        0      0 *:imap2                 *:*                     LISTEN      3535/dovecot    
    tcp        0      0 *:http-alt              *:*                     LISTEN      4257/apache2    
    tcp        0      0 *:http                  *:*                     LISTEN      4257/apache2    
    tcp        0      0 *:tproxy                *:*                     LISTEN      4257/apache2    
    tcp        0      0 *:ssmtp                 *:*                     LISTEN      3712/master     
    tcp        0      0 server4.tuhinbhu:domain *:*                     LISTEN      2072/named      
    tcp        0      0 127.0.0.2:domain        *:*                     LISTEN      2072/named      
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      2072/named      
    tcp        0      0 *:ssh                   *:*                     LISTEN      3281/sshd       
    tcp        0      0 *:smtp                  *:*                     LISTEN      3712/master     
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      2072/named      
    tcp        0      0 *:https                 *:*                     LISTEN      4257/apache2    
    tcp        0      0 *:imaps                 *:*                     LISTEN      3535/dovecot    
    tcp        0      0 *:pop3s                 *:*                     LISTEN      3535/dovecot    
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      1941/amavisd-new (m
    tcp        0      0 localhost.localdom:http localhost.localdo:35018 TIME_WAIT   -               
    tcp        0      0 localhost.localdom:http localhost.localdo:35069 TIME_WAIT   -               
    tcp        0     52 server4.tuhinbhuiya:ssh fip7c249.banglali:54979 ESTABLISHED 4176/0          
    tcp        0      0 localhost.localdo:60957 localhost.localdom:http TIME_WAIT   -               
    tcp6       0      0 [::]:submission         [::]:*                  LISTEN      3712/master     
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      3535/dovecot    
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      3535/dovecot    
    tcp6       0      0 [::]:ssmtp              [::]:*                  LISTEN      3712/master     
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN      2072/named      
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      3281/sshd       
    tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      3712/master     
    tcp6       0      0 localhost:953           [::]:*                  LISTEN      2072/named      
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      3535/dovecot    
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      3535/dovecot    
    tcp6       0      0 localhost:34380         localhost:imap2         TIME_WAIT   -               
    tcp6       0      0 localhost:36725         localhost:imap2         TIME_WAIT   -               
    


    And this is my iptables -L | grep ftp . Where ftp enable.

    Code:
    PAROLE     tcp  --  anywhere             anywhere             tcp dpt:ftp-data
    PAROLE     tcp  --  anywhere             anywhere             tcp dpt:ftp
    
     
  2. srijan

    srijan New Member HowtoForge Supporter

    Which server/distribution you are using??
     
  3. strang3r

    strang3r Member

  4. strang3r

    strang3r Member

    I found this in my syslog, after making a restart.
    Code:
    Dec  4 02:09:17 server4 pure-ftpd: (?@?) [ERROR] Sorry, but that file doesn't exist: [/etc/ssl/private/pure-ftpd.pem]
    Dec  4 02:09:26 server4 pure-ftpd: (?@?) [ERROR] Sorry, but that file doesn't exist: [/etc/ssl/private/pure-ftpd.pem]

    But file do exists... here.

    Code:
    [email protected]:~# ls -la /etc/ssl/private/
    total 16
    drwx--x--- 2 root ssl-cert 4096 Nov 30 20:12 .
    drwxr-xr-x 4 root root     4096 Nov 30 19:20 ..
    -rw------- 1 root root     1704 Dec  3 12:45 pure-ftpd.pem
    -rw-r----- 1 root ssl-cert 1708 Nov 30 19:20 ssl-cert-snakeoil.key
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Stop the firewall and try again. If it works, then you have to define the same passive port range in pure-ftpd and the firewall.
     
  6. strang3r

    strang3r Member

    I disabled firewall but this what I get after pureftp restart, pureftp status check...


    Code:
    [email protected]:~# [FAIL] pure-ftpd is not running ... failed!

    Code:
    Dec  4 02:20:25 server4 pure-ftpd: (?@?) [ERROR] Sorry, but that file doesn't exist: [/etc/ssl/private/pure-ftpd.pem]
    Dec  4 02:20:27 server4 ntpdate[3739]: the NTP socket is in use, exiting
    Dec  4 02:21:01 server4 /USR/SBIN/CRON[3745]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Dec  4 02:22:01 server4 /USR/SBIN/CRON[3765]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Dec  4 02:23:01 server4 /USR/SBIN/CRON[3778]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Dec  4 02:24:01 server4 /USR/SBIN/CRON[3790]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Dec  4 02:25:01 server4 /USR/SBIN/CRON[3806]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Dec  4 02:25:01 server4 /USR/SBIN/CRON[3807]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /dev/null)
    Dec  4 02:26:01 server4 /USR/SBIN/CRON[3871]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Dec  4 02:26:55 server4 pure-ftpd: (?@?) [ERROR] Sorry, but that file doesn't exist: [/etc/ssl/private/pure-ftpd.pem]
    Dec  4 02:27:01 server4 /USR/SBIN/CRON[3945]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    
    Code:
    [email protected]:~# netstat -tap                               
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:imap2                 *:*                     LISTEN      3525/dovecot    
    tcp        0      0 *:http-alt              *:*                     LISTEN      3312/apache2    
    tcp        0      0 *:http                  *:*                     LISTEN      3312/apache2    
    tcp        0      0 *:ssmtp                 *:*                     LISTEN      3698/master     
    tcp        0      0 *:tproxy                *:*                     LISTEN      3312/apache2    
    tcp        0      0 server4.tuhinbhu:domain *:*                     LISTEN      2064/named      
    tcp        0      0 127.0.0.2:domain        *:*                     LISTEN      2064/named      
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      2064/named      
    tcp        0      0 *:ssh                   *:*                     LISTEN      3271/sshd       
    tcp        0      0 *:smtp                  *:*                     LISTEN      3698/master     
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      2064/named      
    tcp        0      0 *:https                 *:*                     LISTEN      3312/apache2    
    tcp        0      0 *:imaps                 *:*                     LISTEN      3525/dovecot    
    tcp        0      0 *:pop3s                 *:*                     LISTEN      3525/dovecot    
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      1933/amavisd-new (m
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      3698/master     
    tcp        0      0 *:mysql                 *:*                     LISTEN      2877/mysqld     
    tcp        0      0 *:submission            *:*                     LISTEN      3698/master     
    tcp        0      0 localhost.localdo:11211 *:*                     LISTEN      2499/memcached  
    tcp        0      0 *:pop3                  *:*                     LISTEN      3525/dovecot    
    tcp        0     52 server4.tuhinbhuiya:ssh fip7c249.banglalio:8607 ESTABLISHED 3926/0          
    tcp        0      0 localhost.localdo:58313 localhost.localdom:http TIME_WAIT   -               
    tcp        0      0 localhost.localdom:http localhost.localdo:60440 TIME_WAIT   -               
    tcp        0      0 localhost.localdom:http localhost.localdo:60451 TIME_WAIT   -               
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      3525/dovecot    
    tcp6       0      0 [::]:ssmtp              [::]:*                  LISTEN      3698/master     
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN      2064/named      
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      3271/sshd       
    tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      3698/master     
    tcp6       0      0 localhost:953           [::]:*                  LISTEN      2064/named      
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      3525/dovecot    
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      3525/dovecot    
    tcp6       0      0 [::]:submission         [::]:*                  LISTEN      3698/master     
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      3525/dovecot   
    
     
  7. strang3r

    strang3r Member

    Made it worked!

    Thanks for your support!.

    I was able to fix it just by recreating a new private key for pureftpd with default attributes. :p

    IF YOU WANT TSL ACTIVE THEN FOLLOW THIS ---

    Activate tls...
    Code:
    echo 1 > /etc/pure-ftpd/conf/TLS
    Move to etc/ssl/private..
    Code:
    cd /etc/ssl/private 
    Create cert...
    Code:
    /etc/ssl/private# openssl req -x509 -nodes -newkey rsa:1024 -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem 
    Change the permission...

    Code:
    chmod 400 pure-ftpd.pem
    Restart service....
    Code:
    /etc/init.d/pure-ftpd-mysql restart

    IF YOU DON'T WANT TSL ACTIVATE THEN FOLLOW THIS -

    Deactive TSL
    Code:
    echo 0 > /etc/pure-ftpd/conf/TLS
    Restart service....
    Code:
    /etc/init.d/pure-ftpd-mysql restart


    Both way works. Now I can access. and service online ;)

    Hope this will help someone else. Who is stuck with user ftp access. and ftp don't shows up in netstats. :p
     
  8. onastvar

    onastvar Member

    My FTP suddenly stopped working, I followed above instructions to fix it, after I restart

    Code:
    /etc/init.d/pure-ftpd-mysql restart
    I get the following:

    Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -H -8 UTF-8 -E -b -D -p 40110:40210 -A -O clf:/var/log/pure-ftpd/transfer.log -Y 0 -J HIGH:MEDIUM:+TLSv1:!SSLv2:!SSLv3 -u 1000 -B

    Code:
    netstat -tap | grep ftp
    tcp 0 0 *:ftp *:* LISTEN 16751/pure-ftpd (SE
    tcp 0 0 localhost:ftp localhost:44464 TIME_WAIT -
    tcp6 0 0 [::]:ftp [::]:* LISTEN 16751/pure-ftpd (SE

    Code:
    ps -aux | grep ftp
    warning: bad ps syntax, perhaps a bogus '-'?
    See http://gitorious.org/procps/procps/blobs/master/Documentation/FAQ
    root 16751 0.0 0.0 41096 996 ? Ss Dec11 0:00 pure-ftpd (SERVER)
    root 19926 0.0 0.0 7776 852 pts/0 S+ 00:09 0:00 grep ftp

    Code:
    cat /proc/user_beancounters
    cat: /proc/user_beancounters: No such file or directory

    SYSTEM > Server > Fileserver if I uncheck Fileserver, monitor shows (green) all OK, however I cannot login to FTP.
    Is this a bug?


    FTP server is offline. Any suggestions how to fix it?
    Code:
    
    
     
    Last edited: Dec 12, 2014
  9. onastvar

    onastvar Member

    I just rebooted server and FTP is working again.
     

Share This Page