Pure-FTP on Ubuntu 18.04 Timeout fetching root Directory

Discussion in 'ISPConfig 3 Priority Support' started by Bob Hall, Nov 5, 2018.

  1. Bob Hall

    Bob Hall New Member HowtoForge Supporter

    Greetings;

    I am running a downloaded OVA (The Perfect Server - Ubuntu 18.04 (Nginx, MySQL, PHP, Postfix, BIND, Dovecot, Pure-FTPD and ISPConfig 3.1) as ready to use virtual machine image download in ovf/ova format, compatible with VMWare and Virtualbox.) that is Ubuntu with Pure-FTP.

    The VM is running behind a pfsense firewall. No issues getting to the webserver, and the rules are in place to allow passthrough of port 21 for ftp. When the ftp client connects to the external IP address that is NAT'd through the firewall, the connection completes, but then times times out Below is what the client see's. I've tried several suggestions found in the forums but no success. please let me know if you have any ideas or suggestions! I have tried both connection types (normal and passive) with no difference.

    Thank you in advance!
    Bob

    << Connection : 1 >>
    << Date Time : 11/4/18 9:14:01 PM >>
    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 03:13. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    USER cipoftptigadmin
    331 User cipoftptigadmin OK. Password required
    PASS ************
    230 OK. Current restricted directory is /
    SYST
    215 UNIX Type: L8
    OPTS UTF8 ON
    200 OK, UTF-8 enabled
    CWD /
    250 OK. Current directory is /
    PWD
    257 "/" is your current location
    TYPE A
    200 TYPE is now ASCII
    PASV
    227 Entering Passive Mode (172,16,0,100,145,45)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Bob Hall

    Bob Hall New Member HowtoForge Supporter

    I tried this, but when i enter this line:
    echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange
    I get permission denied
    if i try:
    sudo echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange
    I get the same message.

    On the firewall I have created a rule to pass ports 30110-40210 to the server (in advance of figuring out the above problem) and will enable once i can get it to work.

    thanks!
    Bob
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    First, become root user by running:

    sudo -s

    then follow the commands from the tutorial.
     
  5. Bob Hall

    Bob Hall New Member HowtoForge Supporter

    now don't I fell silly!

    Thank you very much till! This worked perfectly.

    now on to my next challenge, expanding the drive :)

    Bob
     

Share This Page