Pure-FTP not working after upgrading ISPConfig

Discussion in 'Server Operation' started by Kronz, Oct 18, 2017.

  1. Kronz

    Kronz Member

    So, after updating ISPConfig, pureftp stopped working.
    When I try to connect I get 530 Login incorrect.

    For some reason /var/log/syslog is empty...
     
  2. HSorgYves

    HSorgYves Active Member

    Did you reconfigure services?
     
  3. Kronz

    Kronz Member

    Yes, I reconfigured services.

    So, I reinstalled pure-ftpd-mysql. Now the service at least starts and listens on port 21, BUT:
    when I connect to the server with FileZilla, here is what happens:

    Code:
    Status:    Resolving address of ihost.bg
    Status:    Connecting to 95.43.237.186:21...
    Status:    Connection established, waiting for welcome message...
    Status:    Insecure server, it does not support FTP over TLS.
    Command:    USER default_alexander
    Response:    331 User default_alexander OK. Password required
    Command:    PASS ***********
    Response:    530 Login authentication failed
    Error:    Critical error: Could not connect to server
    After enabling Verbose Logging in pureftpd, I saw in the error log a message that the MYSQL server is down....

    So I created a table FTPD and set up pureftpd to user it, BUT

    When I add a FTP user in ispconfig, it is not added to the pureftpd databse.

    Any ideas ?

    So, how to I configure pure-ftpd's sql for use with ISPConfig ? Any special settings ?

    OK, so I fixed the above by pointing PUREFTPD to the ISPCONFIG db, namely the table ftp_users...

    BUT STILL, I keep getting login incorrect, although Pure-FTPD now connects fine to the databse.

    This is what the syslog looks like now:

    Code:
    [email protected]:~# tail -f /var/log/syslog | grep pure-ftpd
    Oct 20 10:53:05 ihost pure-ftpd: ([email protected]) [INFO] New connection from 84-40-78-192.net1.bg
    Oct 20 10:53:05 ihost pure-ftpd: ([email protected]) [DEBUG] Command [auth] [TLS]
    Oct 20 10:53:05 ihost pure-ftpd: ([email protected]) [DEBUG] Command [auth] [SSL]
    Oct 20 10:53:05 ihost pure-ftpd: ([email protected]) [DEBUG] Command [user] [default_petar]
    Oct 20 10:53:05 ihost pure-ftpd: ([email protected]) [DEBUG] Command [pass] [<*>]
    Oct 20 10:53:11 ihost pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [default_petar]
    Oct 20 10:53:11 ihost pure-ftpd: ([email protected]) [INFO] Logout.
    
    At this point, I am clueless...
     
    Last edited: Oct 20, 2017
  4. If you create any new FTP user, then you see same issue?
     
  5. adamjedgar

    adamjedgar Member

    Going back to your first post,

    Before getting carried away tinkering with server...

    Did you try "plain ftp" instead of over tls...and try switching between active or passive modes? (I know plain ftp is not secure)
     
  6. Its not about connection is secure or not.. The pure-ftpd is unable to recognize the users for authentication..
     
  7. adamjedgar

    adamjedgar Member

    That may or may not be the case...my point is filezilla is useless in its error codes. It throws that generic error all the time...even when there isnt actually a login error. The fact remains the very first error it threw, "ftp over tls isnt supported" tells me he is using the wrong mode and needs to change to basic ftp. Hence my suggestion to first do the most basic thing before completely cocking up a perfectly good system...use basic ftp and if needed, change modes to active or passive (whichever works)!

    Its like having a broken lawnmower...the first thing any mechanic does is check it hasnt run out of fuel (many years ago i used to repair them and you would be suprised how often a non working lawnmower goes into a repair shop because of exactly this most fundamental of reasons)
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig FTP users are in the dbispconfig MySQL database and pure-ftpd connects directly to that database. Maybe this connection is broken. First, check with phpmyadmin that there is a user with this name in the ftp_user table on this server in the dbispconfig database. And which Linux distribution do you use?
     
  9. Yes, exactly. The connection is broken or the table is missing the users when he reconfigured services.
     

Share This Page