pure-ftp-mysql - Authentication failed [SOLVED]

Discussion in 'ISPConfig 3 Priority Support' started by biforme, Sep 17, 2020.

  1. biforme

    biforme Member HowtoForge Supporter

    I Till,
    I have problems with an Ubuntu 18.04 LTS and last ISPConfig on multiserver.
    I have created some new users but can't login.
    The users result in the ftp_user table and the password used seems correct, it starts with: $6$rounds=5000$35
    I also tried to delete the users and recreate them, but without success, in syslog: [WARNING] Authentication failed for user

    Code:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Ubuntu 18.04.4 LTS
     
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.1.15p3
    
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.2.24-0ubuntu***.***.***.***
    
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Other users are working fine, so only some of them are affected? Are you sure that you use the full username incl. prefix? Please post the exact login log from your FTP client.
     
  3. biforme

    biforme Member HowtoForge Supporter

    The FTP users on this server were created just now.
    This is the log (in Italian but translated)
    Status: Connecting at *.*.*.*:21 ...
    Status: Connection established, waiting for welcome message ...
    Status: Server not secure. It does not support FTP over TLS.
    Command: USER brvfm_temp
    Answer: 331 User brvfm_temp OK. Password required
    Command: PASS **********
    Response: 530 Login authentication failed
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so there are no other FTP users that are working on this system? Is this a freshly installed system, which tutorial did you use?
     
  5. biforme

    biforme Member HowtoForge Supporter

    I used the tutorial: The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1
    The server installation dates back to 2 months ago, the FTP accounts I had the need to activate them only today.
    I tried to create a new user to test but like the other one it doesn't work. There are currently 2 ftp users.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have shell users created with the exact same username?
     
  7. biforme

    biforme Member HowtoForge Supporter

    No, there is only one ssh user, but the name is unique.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so please do this:

    Reinstall pure-ftpd-mysql:

    Code:
    apt-get install --reinstall pure-ftpd-mysql
    then run:

    Code:
    cd /tmp
    wget https://www.ispconfig.org/downloads/ISPConfig-3.1.15p3.tar.gz
    tar xvfz ISPConfig-3.1.15p3.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    and choose to reconfigure services during update.
     
  9. biforme

    biforme Member HowtoForge Supporter

    Ok, I have tried without success.
    I reinstalled pure-ftpd-mysql and then reconfigured the services.
    I tried to login, so I deleted the accounts and recreated, again without success.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Double check that you connect to the right server. e.g. by using the IP address of the server as servername instead of a domain or subdomain, your ftp client claims the server does not support tls. Also check pure ftpd log file.
     
  11. biforme

    biforme Member HowtoForge Supporter

    Yes Till, sure. I checked several times before bothering you.
    TLS is disabled due to the needs of some management software that not supporting it.
    I will try to create other users.
     
  12. biforme

    biforme Member HowtoForge Supporter

    I tried to copy a password from another server, without sha512, and I can log in. :-/
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Ubuntu 18.04 definitely supports sha512, so the question is why your server has an issue with securely hashed passwords.
     
  14. biforme

    biforme Member HowtoForge Supporter

    It seems to not support passwords in sha512.
     
  15. biforme

    biforme Member HowtoForge Supporter

    Yes, sure Till, others servers, on ubuntu 18.04, have not problems.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you try a different password, just to ensure that iT#s not an issue with the password. Use for a try a shorter and simpler password.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use different software repositories, especially third party repositories, on this server? Or pure-ftpd-mysql from a different source?
     
  18. biforme

    biforme Member HowtoForge Supporter

    Yes, I also tried a stupid password like: 12345
     
  19. biforme

    biforme Member HowtoForge Supporter

    I use these.
    Code:
    deb http://mirror.hetzner.de/ubuntu/packages bionic main multiverse restricted universe
    deb http://mirror.hetzner.de/ubuntu/packages bionic-backports main restricted universe multiverse
    deb http://mirror.hetzner.de/ubuntu/packages bionic-security main restricted universe multiverse
    deb http://mirror.hetzner.de/ubuntu/packages bionic-updates main multiverse restricted universe
    
    deb http://de.archive.ubuntu.com/ubuntu/ bionic main restricted
    deb http://de.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
    deb http://de.archive.ubuntu.com/ubuntu/ bionic universe
    deb http://de.archive.ubuntu.com/ubuntu/ bionic-updates universe
    
    deb http://de.archive.ubuntu.com/ubuntu/ bionic multiverse
    deb http://de.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
    deb http://de.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
    
    deb http://security.ubuntu.com/ubuntu bionic-security main restricted
    deb http://security.ubuntu.com/ubuntu bionic-security universe
    deb http://security.ubuntu.com/ubuntu bionic-security multiverse
    deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable
    
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Seem to be the normal repositories.

    I've updated a test server to the latest Ubuntu 18.04 and tested with ISPConfig 3.1.15p3 there and FTP works, so it's not a general issue as I guessed. You wrote that you use a multiserver system, did you check that the FTP user is really in ftp_user table of the affected node and not just on the master?
     
    biforme likes this.

Share This Page