Pure-FTP Login Problem

Discussion in 'General' started by linus3xx, Jan 13, 2012.

  1. linus3xx

    linus3xx New Member

    I'm at my wit's end - I'm hoping someone can help me out here.

    I've been running ISPConfig3 for over a year. Today my FTP access has decided to just quit working. I'm seeing the same thing over and over in my FTP Client (FileZilla) - MLSD timeouts:

    Code:
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:	220-You are user number 1 of 50 allowed.
    Response:	220-Local time is now 16:47. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	USER XXXXX_base
    Response:	331 User XXXXX_base OK. Password required
    Command:	PASS ************
    Response:	230-User XXXXX_base has group access to:  client1  sshusers
    Response:	230 OK. Current restricted directory is /
    Command:	SYST
    Response:	215 UNIX Type: L8
    Command:	FEAT
    Response:	211-Extensions supported:
    Response:	 EPRT
    Response:	 IDLE
    Response:	 MDTM
    Response:	 SIZE
    Response:	 REST STREAM
    Response:	 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Response:	 MLSD
    Response:	 ESTP
    Response:	 PASV
    Response:	 EPSV
    Response:	 SPSV
    Response:	 ESTA
    Response:	 AUTH TLS
    Response:	 PBSZ
    Response:	 PROT
    Response:	211 End.
    Status:	Connected
    Status:	Retrieving directory listing...
    Command:	PWD
    Response:	257 "/" is your current location
    Command:	TYPE I
    Response:	200 TYPE is now 8-bit binary
    Command:	PORT 72,58,234,181,172,199
    Response:	200 PORT command successful
    Command:	MLSD
    Error:	Connection timed out
    Error:	Failed to retrieve directory listing
    I've tried everything I can think of - Passive & Active mode, opening a different set of ports on the router, upgrading FileZilla, router firmware upgrade, restarting Pure-Ftpd, changing the Passive ports in Pure-Ftpd (including opening the firewall for said ports), using a non-secure connection, etc and so on.

    I've been at this for 5 hours. No matter what I try, I can't get a connection. It always times out at the MLSD command.

    I have to get this site updated today and I'm completely stumped. Does anyone have any ideas? Even a non-FTP solution at this point.
     
  2. linus3xx

    linus3xx New Member

    Resolved

    OK - finally got this resolved. Figured I'd give an update in case anyone else also runs into this brick wall.

    First, I gave up on FTP and just hand-edited the PHP and HTML files through Putty using VI. It was fairly brutal but it worked and it saved me from losing a client.

    Now that the crisis was over, I started downloading various FTP clients and just trying them one after the other. I finally had success with WinSCP. Don't ask me why that one worked when all the others didn't - have no idea. But I could finally connect, get a directory listing, transfer files back and forth, etc.

    Anyway, miserable 12 hours but glad it's finally over.
     
  3. PermaNoob

    PermaNoob New Member

    It's also easy to edit the files using winscp. Just right-click and select edit.
     
  4. linus3xx

    linus3xx New Member

    Yeah, I'm really liking WinSCP. I still have no idea why FileZilla just decided to quit working like that after a year. Maybe a recent update broke something.

    What I've found with WinSCP is that I can now connect in Passive mode whereas before, with FileZilla, I could only get to the box in Active mode.

    I've let my users know that they need to switch to WinSCP. So far, no complaints at all.

    Thanks for the tip on editing - I'll give that a try!
     
  5. PermaNoob

    PermaNoob New Member

    also convenient for reading log files, etc.
     
  6. aldo

    aldo Member HowtoForge Supporter

    I have the same problem.

    I was looking for a reason, without success.

    Luckily I found your post.

    Windows 7 / Filezilla <--> PureFTP / Debian 6 + ISPConfig3
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely you use a firewall where the passive ftp ports are closed. Use actibe ftp mode or open the passive ports in the firewall.
     
  8. aldo

    aldo Member HowtoForge Supporter

    Thank you Till.

    Standard FTP works as expected in active and passive mode.

    On the server firewall all FTP ports are open (20,21,989,990)

    With FTPES atctive mode:
    Whit PTFES passive mode:
    On MLSD command stops.
     

Share This Page