Pure-FTP does not work

Discussion in 'Installation/Configuration' started by Lunardi Marco Agisander, Mar 24, 2014.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Ds the domain ftp.lunardi.eti.br point to the correct server in dns?
    2) Which error do you get?
    3) Do you use the correct ftp username inkl. prefix? The ftp username to be used in the ftp client is something like c1suer or defaultuser and not just user.
     
  2. Hello again Till,

    1) Ds the domain ftp.lunardi.eti.br point to the correct server in dns?
    - Yes. ftp.lunardi.eti.br <--> 177.70.26.92

    2) Which error do you get?
    - What is the log file?

    3) Do you use the correct ftp username inkl. prefix? The ftp username to be used in the ftp client is something like c1suer or defaultuser and not just user.
    - Yes, I use login: lunardi_ftp and password: qwerty

    Thanks for the help.
    Lunardi
     
  3. Hello to all!
    Please anyone who can help?
     
  4. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Please use USER=defaultlunardi_ftp & password=qwerty like this only

    logs in /var/log/, espacially syslog, mesages and pur-ftpd log.

    Br//
    Srijan
     
  5. Hello Srijan, and thanks for feedback.

    3)
    The username correct is lunardi_ftp and not defaultlunardi_ftp

    2)
    Tests with username lunardi_ftp:

    [email protected]:/var/log# tail -f syslog | grep pure-ftp
    Mar 28 11:11:43 cerato pure-ftpd: ([email protected]) [INFO] New connection from 187.107.211.85
    Mar 28 11:11:43 cerato pure-ftpd: ([email protected]) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-SHA256, 256 secret bits cipher
    Mar 28 11:11:47 cerato pure-ftpd: ([email protected]) [INFO] lunardi_ftp is now logged in


    But not working!
     
  6. srijan

    srijan New Member HowtoForge Supporter

    Hi

    What is your ftp-client?
    I do prefer file-zilla for that. See here in ISPConfig if you create any ftp-user then it have prefixed default name. e.g. if you created the user through ISPConfig webinterface viz. user1 then you need to do login as defaultuser1 for ftp login through ftp-client.

    Br//
    Srijan
     
  7. srijan

    srijan New Member HowtoForge Supporter

    We prefer to use ISPConfig webinterface to make the ftp-users.

    Br//
    Srijan
     
  8. Hello Srijan, and thanks for feedback.

    I'm use the FileZilla.

    I have a client with the username "lunardi" and a login to ftp-user so:
    username: lunardi_ftp

    In tests with FileZilla, do this:

    host: ftpes://ftp.lunardi.eti.br
    username: lunardi_ftp
    passwort: qwerty
    port: 21


    But not working, see below logs:

    Mar 28 11:52:52 cerato pure-ftpd: ([email protected]) [INFO] New connection from 187.107.211.85
    Mar 28 11:52:52 cerato pure-ftpd: ([email protected]) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-SHA256, 256 secret bits cipher
    Mar 28 11:52:56 cerato pure-ftpd: ([email protected]) [INFO] lunardi_ftp is now logged in

    I also use ISPConfig webinterface to create the ftp-users.

    Please help.

    Thanks again.
     
  9. Hello to all!
    Please anyone who can help?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    According to the log, it worked. If you cant see ftp folders, then the most likely reason is a firewall that blocks the passive ftp ports. if you run a firewall, stop it and try again.
     
  11. Hy Till,

    Thanks for the reply.

    I'm run a firewall from ISPConfig. How allow/release passive ftp ports?
     
  12. Hello to all!
    Please anyone who can help?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page