pure-ftp CLIENTNAME on ISPConfig 3?

Discussion in 'General' started by JESUSSAVES, Sep 24, 2011.

  1. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    Hi,

    Installed Fedora 15 - ISPConfig 3 following instructions.

    I've never used pure-ftp prior to this installation so I don't where it keeps it's configuration files.

    I've discovered where my CLIENTNAME is listed (under the ftp user list).

    I can connect to the server with pure-ftp with a Linux user id, but not with an ISPConfig defined ftp user. I'm using FileZilla on port 22 as the ftp client. I used my domain name (with the tld of course) but not the protocol as the host.

    I'm at a loss to know what to do.

    Please could someone give me advice. Thanks.
     
    Last edited: Sep 24, 2011
  2. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    /etc/pure-ftpd/pure-ftpd.conf

    The configuration file is setup as it should be.

    I can only get connected on port 22 as SSH.

    On port 21 as TLSES I get an error.

    I got past accepting my certificate, that's OK.

    FileZilla log screen shows last successful entry" "227 entering passive mode (192...)"

    Then immediately I get a Status:"Server sent passive reply with unroutable address. Using server address instead"

    Then it dies - error messages in red.

    /var/log/messages shows login successful then logout, but no errors.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Did you try both active and passive transfers in your FTP client?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats most likely a firewall issue. Try to disable the firewall and if that works, define a passive port range in the firewall and the pureftpd configuration.
     
  5. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    yes both active and passive with firewall down

    Yes, I've tried both active and passive (port 990) with the firewall disabled.

    One irregularity was that I caught that I had not set TLS 1 until after I installed ISPConfig 3. But after restarting pure-ftpd and rebooting still it didn't work.

    After having problems I discovered the FTP HOWTO "Virtual Hosting With PureFTPd And MySQL (Incl. Quota And Bandwidth Management) On Fedora 14". I'm not sure whether that is just for ISPConfig 2, but I haven't done that stuff.

    Thank you for your help.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This tutorial is incompatible with all ispconfig versions, so dont use that on a ispconfig server. The only tutorial that is required to setup the server is the perfect setup guide for ispconfig 3. Dont use the guide for ispconfig 2 or any oher tutorial. Mske sure that you folowed every command exactly. Port 990 is not the ftp port. Please use the normal ftp port 21 to connect to ftp. Are connections withot tls are working fine?
     
  7. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    only works on 22 SSH

    The first attempt was 21 with TLSES and the second with plain ftp on 21.

    Status: Selected port usually in use by a different protocol.
    Status: Resolving address of delcowebhosting.com
    Status: Connecting to 71.225.4.213:21...
    Status: Connection established, initializing TLS...
    Error: Connection timed out
    Error: Could not connect to server
    Status: Waiting to retry...
    Status: Resolving address of delcowebhosting.com
    Status: Connecting to 71.225.4.213:21...
    Status: Connection established, initializing TLS...
    Error: Connection timed out
    Error: Could not connect to server
    Status: Resolving address of delcowebhosting.com
    Status: Connecting to 71.225.4.213:21...
    Status: Connection established, waiting for welcome message...
    Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response: 220-You are user number 1 of 50 allowed.
    Response: 220-Local time is now 18:10. Server port: 21.
    Response: 220-This is a private system - No anonymous login
    Response: 220-IPv6 connections are also welcome on this server.
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: USER delco001
    Response: 331 User delco001 OK. Password required
    Command: PASS ******
    Response: 230 OK. Current restricted directory is /
    Command: SYST
    Response: 215 UNIX Type: L8
    Command: FEAT
    Response: 211-Extensions supported:
    Response: EPRT
    Response: IDLE
    Response: MDTM
    Response: SIZE
    Response: REST STREAM
    Response: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Response: MLSD
    Response: AUTH TLS
    Response: PBSZ
    Response: PROT
    Response: UTF8
    Response: ESTA
    Response: PASV
    Response: EPSV
    Response: SPSV
    Response: ESTP
    Response: 211 End.
    Command: OPTS UTF8 ON
    Response: 200 OK, UTF-8 enabled
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is your current location
    Command: TYPE I
    Response: 200 TYPE is now 8-bit binary
    Command: PASV
    Response: 227 Entering Passive Mode (71,225,4,213,57,240)
    Command: MLSD
    Error: Connection timed out
    Error: Failed to retrieve directory listing
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats a firewall issue, the connection gets interrupted when ftp switches to another port. Please turn of the firewall and try again. Be aware that it takes at least one minute until the ispconfig firewall is turned off. It may also be a firewall at yor isp or datacenter which blocks the connection.
     
  9. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    GnuTLS error -53: Error in the push function

    With firewalls disabled and off I still got the problem.

    I Googled the error:"GnuTLS error -53: Error in the push function" and found a discussion thread on a FileZilla forum about a confirmed bug in gnuTLS. (I've have a different Linux kernel level 2.6.4 than the instructions on howtoforge.com). My gnuTLS is gnutls-2.10.5-1.fc15.x86_64 while my FileZilla agent uses 2.10.4.

    So I downloaded a different FTP client and now everything works as it should.

    Thanks again,
    JESUSSAVES
     

Share This Page