Pure domain DNS doesn't work

Discussion in 'Installation/Configuration' started by SyRenity, Dec 3, 2006.

  1. SyRenity

    SyRenity New Member

    Hi.

    I have one site that doesn't work when accessed via pure domain (i.e. http://somesite.com) - it shows the ISPConfig Shared IP page. It does work when accessed via www servername (http://www.somesite.com).

    The rest of the site work with pure domain without problems. Any idea what can be done here?

    Thanks.
     
  2. edge

    edge HowtoForge Supporter

    two things that could be wrong (hard to say with the info you are giving)

    a) Create at pure domain an A record with as host @ and point it to your server.

    or

    b) In ISPconfig go to ISPmanager, and select the domain (somesite.com)
    Now go to the Co-domains tab, and click on NEW. Leave the "Hostname:" empty, and enter in the "Domain:" somesite.com
    When done, click on save.
     
    Last edited: Dec 3, 2006
  3. SyRenity

    SyRenity New Member

    Hi.

    I was missing the @ record. I added it, hopefully it will resolve the problem.


    Update: Unfortunately, it didn't work. I added the @ record, and the Co-domains tab already had the somesite.com in it.

    The domain in question is www.hatarsi.com

    Thanks.
     
    Last edited: Dec 4, 2006
  4. falko

    falko Super Moderator

    What's in your Vhosts_ispconfig.conf?
     
  5. SyRenity

    SyRenity New Member

    Here it is:

    ######################################
    # Vhost: www.hatarsi.com:80
    ######################################
    #
    #
    <VirtualHost 64.187.96.17:80>
    ServerName www.hatarsi.com:80
    ServerAdmin webmaster@hatarsi.com
    DocumentRoot /var/www/web14/web
    ServerAlias hatarasi.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web14/log/error.log
    Alias /error/ "/var/www/web14/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
    </VirtualHost>

    Thanks.
     
  6. edge

    edge HowtoForge Supporter

  7. falko

    falko Super Moderator

    The problem is you created a Co-Domain hatarasi.com, not hatarsi.com!
     
  8. SyRenity

    SyRenity New Member

    Thanks, this solved this issue :)!
     

Share This Page