PseudoStreaming with FlowPlayer, ffmpeg and Lighttpd

Discussion in 'Suggest HOWTO' started by pd_voodoo, Mar 2, 2010.

  1. pd_voodoo

    pd_voodoo New Member

    Hi guys,

    I am finding trouble getting pseudostreaming to work with Lighttpd, Flowplayer on ubuntu 9.10
    I followed instructions as it is from :

    http://www.howtoforge.com/video_streaming_lighttpd_flowplayer_p3


    When I tried loading the sample implementation, nothing shows up ! I have installed Lighttpd over an different port (as Apache already installed) and the root-directory being different than /var/www/ as /var/www/sample/

    Can someone help me out?

    Thanks
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Any errors in the lighttpd logs?
     
  3. pd_voodoo

    pd_voodoo New Member

    Re: Lighttpd + pseudo streaming ...

    Hi,

    Thanks for replying.. Below is the error log and attached is the access.log file.
    Also, PHP is working fine on Lighttpd but the flv along with flow player isn't.
    I have also attached conf file and the php script I'm using.


    error.log

    2010-02-28 07:50:32: (server.c.1355) [note] graceful shutdown started
    2010-02-28 07:50:32: (server.c.1469) server stopped by UID = 0 PID = 24753
    2010-02-28 07:50:33: (log.c.97) server started
    2010-03-01 13:44:25: (server.c.1469) server stopped by UID = 0 PID = 27585
    2010-03-01 13:44:25: (log.c.97) server started
    2010-03-01 14:30:43: (server.c.1469) server stopped by UID = 0 PID = 27992
    2010-03-01 14:30:44: (log.c.97) server started
    2010-03-02 11:55:35: (server.c.1469) server stopped by UID = 0 PID = 29841
    2010-03-02 11:55:36: (log.c.97) server started



    Thanks again.
     

    Attached Files:

  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  5. pd_voodoo

    pd_voodoo New Member

    #Falko: Thanks..I have it up and running now via Lighttpd.. though, its not streaming.. do I need to add certain flowplayer plugin along with the player .js to make it work ? or do something else..

    If have already injected metadata using flvtool2 as :

    $ flvtool2 -U video.flv

    Thanks for you help. I appreciate it.
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I got it working without any FlowPlayer plugins. Are the paths in your PHP file correct?
     
  7. pd_voodoo

    pd_voodoo New Member

    Streaming :(

    Hi,

    The php and config file are just like the ones you described in the tutorial. Only new thing I had to do was changing converted videos permissions to allow flvtool2 to work on it.

    The video loads up fine via lighttpd (running on port 8080 for now), but with no seeking/streaming. I assumed that the metadata didn't get injected well, but it is there. I have attached the injected meta in the flv file using -P option of flvtool2.

    Could you guess what might be happening ?

    Thanks.
     

    Attached Files:

  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you get any errors when you converted the video to flv with ffmpeg?
     
  9. pd_voodoo

    pd_voodoo New Member

    Hi,

    No errors as such.. Still, I have attached the media conversion and metadata injection using flvtool2 logs for you to take a look. Thanks again for you help.
     

    Attached Files:

  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You're using the ffmpeg package from the Ubuntu repositories, but unfortunately it has no libmp3lame support. Please install the ffmpeg package from www.debian-multimedia.org (works on Ubuntu as well).
     
  11. pd_voodoo

    pd_voodoo New Member

    libmp3lame

    Hi,

    Thanks for pointing that out. I tried installing ffmpeg from debian-multimedia (following the steps in the tutorial you mentioned above - i.e. by aptitude install), it didn't install libmp3lame. When I manually tried installing *.deb from the site, there were many dependencies I couldn't locate. Hope you could help.

    Thanks again.
     
  12. pd_voodoo

    pd_voodoo New Member

    Hey,

    Just an update.. I think I have the libmp3lame installed. Have attached the conversion log of ffmpeg and flvtool2. Still no luck with streaming. Please let me know if you find something.

    Thanks.
     

    Attached Files:

  13. pd_voodoo

    pd_voodoo New Member

    Finally fixed !!

    Hi,

    Finally able to fix the streaming issue. It looked like it required the pseudostreaming plugin for enable forward seeking.
     

Share This Page