Proxy Port forwarding or VPN client

Discussion in 'Installation/Configuration' started by Scypher, Apr 30, 2010.

  1. Scypher

    Scypher New Member

    Hello everyone, you are my last hope guys... maybe my google-skill is not high enough or maybe I'm in the end of my patience.

    The problem is:

    I'm behing firewall at work "" and I'm trying to tunnel it via ssh tunnel.
    I started a vServer on with Debian Lenny package.
    There, I've installed the Squid proxy server, wich I googled up.

    What I'm trying to tunnel is the WoW game. Official info from their web about ports can be found here.

    I tried to follow few tutorials on web, but it didn't work. My co-worker suggested that I should try entering only the ports them selves to SSH tunnel in putty and select it to "dynamic".
    It didn't work. :(

    I've also folowed the link up there. No succes with that. So I gave up and decided to ask you guys here.

    I still have the loopback adapter installed, so if it helps... I'll be glad.

    My friend told me, that other possibility is a VPN server on my vserver and connect through VPN client. I got my self a Kerio VPN client, but configuring the VPN server is something, I don't understand.

    Someone please help me. I just need to break trough that firewall.. WoW doesn't matter, I just need to hack this. :rolleyes: ;)
    Last edited: Jun 4, 2010
  2. Scypher

    Scypher New Member

    anyone? please... :eek:
  3. Mark_NL

    Mark_NL Member

    you have 2 options (since 1 ssh tunnel won't work)

    1. Setup a VPN, connect to it, and you're done.

    On your vserver (debian) .. install openvpn it's very easy to setup, p2p is the easiest, after that let your vserver do some routing to the outside world, and you're good to go.

    some tuts about openvpn:

    2. Stop playing wow at work, and start farming gold when you're at home ;)
  4. Rapid2214

    Rapid2214 New Member

    I would recommend using PPTP, in ubuntu it take 5 mins to setup but not sure if the firewall would block it...
    Either way the firewall would become an issue, you could make your vpn server listen on port 80 (almost certainly allowed by firewall) and then your good to go.
  5. Scypher

    Scypher New Member

    Thank you for your recommendations. I'll give it a try.

Share This Page