[proxy:error] No such file or directory: AH02454: FCGI: adding a 2nd php (5.6)

Discussion in 'Installation/Configuration' started by Stelios, Sep 26, 2020.

  1. Stelios

    Stelios Member

    Hi all,
    I had to install PHP 5.6 due to old software. I followed the tutorial at:
    https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/
    which suppose to cover Debian 10 too.
    I did exactly what the tutorial says; PHP 7 works fine but 5.6 doesn't. It throws the following error:

    Code:
    [Sat Sep 26 10:26:20.294362 2020] [proxy:error] [pid 20784] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/php7.3-fpm/web18.sock (*) failed
    [Sat Sep 26 10:26:20.294449 2020] [proxy_fcgi:error] [pid 20784] [client 178.147.196.46:54112] AH01079: failed to make connection to backend: httpd-UDS
    It seems that it is searching for PHP 7 while I've got that site configured via ISPconfig admin to use PHP 5.6 fpm. The above tutorial had wrong the paths for Debian 10 so I've adjusted them properly (PHP is under /etc/php/5.6/fpm/ and not on those listed on the tutorial).
    Switching to PHP-cgi works but it doesn't on FPM.

    Any help is very much appreciated.

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not the case, the number 7.3 in the path does not stand for a specific PHP version.

    Check the reason why php5.6-fpm could not start

    Code:
    service php5.6-fpm status
     
  3. Stelios

    Stelios Member

    The service is running from what I can tell.
    Code:
    [email protected]:~# service php5.6-fpm status
    ● php5.6-fpm.service - The PHP 5.6 FastCGI Process Manager
       Loaded: loaded (/lib/systemd/system/php5.6-fpm.service; enabled; vendor preset: enabled)
       Active: active (running) since Sat 2020-09-26 10:19:58 EEST; 1h 44min ago
         Docs: man:php-fpm5.6(8)
      Process: 20529 ExecStartPost=/usr/lib/php/php-fpm-socket-helper install /run/php/php-fpm.sock /etc/php/5.6/fpm/pool.d/
     Main PID: 20526 (php-fpm5.6)
       Status: "Processes active: 0, idle: 2, Requests: 1, slow: 0, Traffic: 0req/sec"
        Tasks: 3 (limit: 4915)
       Memory: 17.8M
       CGroup: /system.slice/php5.6-fpm.service
               ├─20526 php-fpm: master process (/etc/php/5.6/fpm/php-fpm.conf)
               ├─20527 php-fpm: pool www
               └─20528 php-fpm: pool www
    
    Sep 26 10:19:58 web1 systemd[1]: Starting The PHP 5.6 FastCGI Process Manager...
    Sep 26 10:19:58 web1 systemd[1]: Started The PHP 5.6 FastCGI Process Manager.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Restart the php5.6-fpm service and try accessing the website again.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    And take care that we website is set to php5.6-fpm at that moment and not to php-fcgi or an other php version.
     
  6. Stelios

    Stelios Member

    @till I've restarted the service many times without any luck. It seems that somehow the process was still running.
    Once I stopped completely the service and started again it worked. Very strange.

    Thanks a lot
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    On Debian 10, you should stop using command service to stop and start services. Instead use systemctl, like
    Code:
    systemctl status php5.6-fpm
    systemctl stop php5.6-fpm
    systemctl start php5.6-fpm
    
     

Share This Page