Protect directory BUG .htpasswd

Discussion in 'Installation/Configuration' started by CubAfull, Aug 2, 2008.

  1. CubAfull

    CubAfull New Member

    After creating a protected directory in ISPConfig 2.2.24 Web-FTP to enter my joomla administration I get an 500 Error after login to the .htaccess window.

    in my /var/www/web1/log/error.log i found...

    Code:
    [Sat Aug 02 15:50:57 2008] [error] [client xxx.xxx.xxx.xxx] (2)No such file or directory: Could not open password file: /var/www/web1/administrator/.htpasswd
    [Sat Aug 02 15:51:08 2008] [error] [client xxx.xxx.xxx.xxx] (2)No such file or directory: Could not open password file: /var/www/web1/administrator/.htpasswd
    [Sat Aug 02 15:51:18 2008] [error] [client xxx.xxx.xxx.xxx] (2)No such file or directory: Could not open password file: /var/www/web1/administrator/.htpasswd
    
    The problem is that the script does not include the web directory in .htaccess

    After replacing manually in .htaccess
    Code:
    AuthUserFile /var/www/web1/administrator/.htpasswd
    
    to
    
    AuthUserFile /var/www/web1/web/administrator/.htpasswd
    everything worked perfectly :)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    We will check this.
     
  3. CubAfull

    CubAfull New Member

    Thanks falko :)

    Maybe this happens when you change the default FTP directory ?. I changed mine to
    Code:
    DefaultRoot ~/web
     
    Last edited: Aug 4, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    In your proftpd.conf? No, this doesn't have any effect on ISPConfig.
     

Share This Page