ProFTPD (TLS) / Can't login whit another domain

Discussion in 'HOWTO-Related Questions' started by hazelnut, May 28, 2014.

  1. hazelnut

    hazelnut New Member

    i have installed ProFTPD with TLS support from this tutorial for a secured FTP. I have multiple Domains and i can't login with another domain as my main-domain. I have used proftpd whitout TLS in de past time and there, i was able to us another domain to connect to ftp.

    This is the error, i get when i trying to connect with antoher domain:
    command:    AUTH TLS
    answer: 500 AUTH not understood
    Here is my proftpd config file:
  2. srijan

    srijan New Member HowtoForge Supporter

    Please refer the thread, it might help you.
  3. hazelnut

    hazelnut New Member

    No, that doesn't help. Look: My Main-Domain is and i can login through proftpd and tls with any user i created, on this domain.

    as an example:

    --> This worked

    --> This doesn't work

    .. and with proftpd whitout tls, i can login with all domains. Do you understand my problem? :)

    Maybe, this is a problem with the tls certificate i created? I've used as FQDN. Maybe it is not ready for another domains?
    Last edited: May 29, 2014
  4. securecloud

    securecloud New Member

    running some tests


    I'm running some tests on a Debian Lenny machine with proftp.
    Installation and everything works fine, as long as I don't activate TLS.

    In the moment I activate TLS I have huge problems.

    Is it a problem regarding the FTP-Client? Or my config?

    My proftpd.conf (TLS Part):
    TLSEngine on
    TLSRequired on
    TLSLog /var/log/ftp_tls.log
    TLSProtocol SSLv23
    TLSOptions NoCertRequest
    TLSRSACertificateFile /etc/ssl/private/
    TLSRSACertificateKeyFile /etc/ssl/private/
    TLSVerifyClient off

    The TLS-Log
    Oct 26 22:15:26 mod_tls/2.1.2[2908]: using default OpenSSL verification
    locations (see $SSL_CERT_DIR environment variable)
    Oct 26 22:15:36 mod_tls/2.1.2[2908]: TLS/TLS-C requested, starting TLS
    Oct 26 22:15:36 mod_tls/2.1.2[2908]: TLSv1/SSLv3 connection accepted, using
    cipher DHE-RSA-AES256-SHA (256 bits)
    Oct 26 22:15:36 mod_tls/2.1.2[2908]: Protection set to Private
    Oct 26 22:15:56 mod_tls/2.1.2[2908]: Protection set to Private

    How can I find out more about this?
    Which client can I use, to avoid that the client is the problem? I'm running
    currently an Ubuntu 7.10 but I think I can manage to install an appropiete

    I'm happy about every hint!

    Kind Regards,
    Secure Cloud
  5. hazelnut

    hazelnut New Member

    @securecloud Try to use Filezilla! As i write it yesterday, i can properly login through FTP with TLS with my Main-Domain.

    My problems are only the other Domains.
  6. hazelnut

    hazelnut New Member

    Update: My issue is fixed. It was a problem with my DNS settings.

Share This Page