proftpd segfaulting/no logins possible, ispconfig 2.2.15

Discussion in 'General' started by ronee, Aug 15, 2007.

  1. ronee

    ronee HowtoForge Supporter

    Not sure if something went awry in this install or something else is wrong, I have a number of ispconfig systems none of which exhibit this issue (but also none are running 2.2.15, only earlier versions).

    The issue is, when a valid user attempt to login via ftp, the server apparently closes the connection after the correct password is transmitted. /var/log/messages has entries like this:

    Aug 15 03:59:18 interactive proftpd[25851]: interactive.xxxx.net (xx.xxx.xx.x
    [yy.y.y.yy]) - FTP session opened.
    Aug 15 03:59:18 interactive proftpd: PAM (ftp) illegal module type: M-1.0
    Aug 15 03:59:18 interactive proftpd[25851]: interactive.xxxx.net (xx.xx.xx.xxx [xx.xx.xx.xxx]) - ProFTPD terminating (signal 11)
    Aug 15 03:59:18 interactive proftpd[25851]: interactive.xxx.net (xx.xxx.xx.x
    [xx.xx.xxx.x]) - FTP session closed.
    Aug 15 03:59:18 interactive kernel: proftpd[25851]: segfault at 0000000000000000
    rip 0000003415e04b0f rsp 0000007fbfffe850 error 4

    I've done some searching, haven't found much useful info, any input would be of interest.
     
  2. till

    till Super Moderator

    Make sure that you installed all updates for your linux distribution. If there is no update available that fixes the problem, then it might be a hardware problem.
    Theb you should check your hardware with e.g. memcheck.
     

Share This Page