Proftpd running.. but something munged?

Discussion in 'Server Operation' started by dbrooke, Oct 24, 2007.

  1. dbrooke

    dbrooke New Member


    It appears proftpd is running (when I do a netstat) but I can't connect to it with ISPConfig and running some debugging reveals some sort of error:

    [email protected]:/home/donovan# proftpd -t
    Checking syntax of configuration file
    - setting default address to
    Syntax check complete.

    [email protected]:/home/donovan# proftpd -n -c /etc/proftpd.conf
    - setting default address to
    localhost.localdomain - Failed binding to, port 21: Address already in use
    localhost.localdomain - Check the ServerType directive to ensure you are configured correctly.

    [email protected]:/home/donovan# proftpd -d 5
    - mod_ctrls/0.9.4: binding ctrls socket to '/var/run/proftpd/proftpd.sock'
    - parsing '/etc/proftpd/proftpd.conf' configuration
    - parsing '/etc/proftpd/modules.conf' configuration
    - mod_tls/2.1.1: using OpenSSL 0.9.8e 23 Feb 2007
    - disabling runtime support for IPv6 connections
    - DenyFilter: compiling deny regex '\*.*/'
    - <IfModule>: using 'mod_tls.c' section at line 90
    - <IfModule>: skipping 'mod_quota.c' section at line 94
    - <IfModule>: skipping 'mod_ratio.c' section at line 98
    - <IfModule>: using 'mod_delay.c' section at line 106
    - <IfModule>: using 'mod_ctrls.c' section at line 110
    - mod_ctrls/0.9.4: closing ctrls socket '/var/run/proftpd/proftpd.sock' (3)
    - <IfModule>: using 'mod_ctrls_admin.c' section at line 118
    - parsing '/etc/proftpd_ispconfig.conf' configuration
    - setting default address to
    localhost.localdomain -
    localhost.localdomain - Config for Debian:
    localhost.localdomain - DeferWelcome
    localhost.localdomain - DefaultServer
    localhost.localdomain - ShowSymlinks
    localhost.localdomain - TimeoutNoTransfer
    localhost.localdomain - TimeoutStalled
    localhost.localdomain - TimeoutIdle
    localhost.localdomain - DisplayLogin
    localhost.localdomain - DisplayFirstChdir
    localhost.localdomain - ListOptions
    localhost.localdomain - DenyFilter
    localhost.localdomain - UserID
    localhost.localdomain - UserName
    localhost.localdomain - GroupID
    localhost.localdomain - GroupName
    localhost.localdomain - Umask
    localhost.localdomain - DirUmask
    localhost.localdomain - AllowOverwrite
    localhost.localdomain - TransferLog
    localhost.localdomain - TLSEngine
    localhost.localdomain - DelayEngine
    localhost.localdomain - DefaultRoot
    localhost.localdomain - IdentLookups
    localhost.localdomain - ServerIdent
    localhost.localdomain -
    localhost.localdomain - Config for Debian:
    localhost.localdomain - DefaultRoot
    localhost.localdomain - AllowOverwrite
    localhost.localdomain - Umask
    localhost.localdomain - mod_ctrls/0.9.4: binding ctrls socket to '/var/run/proftpd/proftpd.sock'

    [email protected]:/home/donovan# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 4156/mysqld
    tcp 0 0 *:81 *:* LISTEN 17368/ispconfig_htt
    tcp 0 0 *:ftp *:* LISTEN 19043/proftpd: (acc [snip]

    Thanks for any help on this!

  2. falko

    falko Super Moderator ISPConfig Developer

    Can you kill all Proftpd instances and then start it again?
  3. dbrooke

    dbrooke New Member

    yes, done... However, now I'm thinking it was actually working and that I didn't know how to use ISPConfig! I think this is one of those RTFM things... because I believe I just had to set up a site first in ISPConfig. Now that I have a site set up, Web-FTP is not hanging. ??

    It appears I am good to go until my next noob confusion. :)


Share This Page