ProFTPD Refuse Connection

Discussion in 'Installation/Configuration' started by hd2000, Nov 4, 2006.

  1. hd2000

    hd2000 New Member

    When I try to connect thru ftp client to my proFTPD on port 21, the proFTPD refuse me before the authentication, this happen before I edit the configuration.

    This is the error :

    [R] Connecting to ftp.winstonjourney.com -> DNS=ftp.winstonjourney.com IP=66.150.227.167 PORT=21
    [R] Connected to ftp.winstonjourney.com
    [R] Connection failed (Connection lost)

    But when I do a netstat -a, looks like proFTPd is listening on port 21

    Can someone take a look at my configuration

    Code:
    # This is a basic ProFTPD configuration file (rename it to 
    # 'proftpd.conf' for actual use.  It establishes a single server
    # and a single anonymous login.  It assumes that you have a user/group
    # "nobody" and "ftp" for normal operation and anon.
    
    ServerType                      inetd
    DefaultServer                   on
    DeferWelcome off
    ShowSymlinks on
    MultilineRFC2228 on
    DefaultServer on
    AllowOverwrite on
    
    TimeoutNoTransfer 600
    TimeoutStalled 600
    TimeoutIdle 1200
    
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    LsDefaultOptions "-l"
    
    DenyFilter \*.*/
    Port 21
    MaxInstances 30
    
    # Set the user and group that the server normally runs at.
    User nobody
    Group nobody
    
    # Normally, we want files to be overwriteable.
    <Directory /*>
      Umask 022 022
      AllowOverwrite                on
    </Directory>
    
    # chroot for all users of the group ftpusers
    DefaultRoot ~ ftpusers
    
    <Limit LOGIN>
            AllowGroup ftpusers
            DenyAll
    </Limit>
    
    # disable root login and require a valid shell (from /etc/shells)
    <Global>
    RootLogin off
    RequireValidShell on
    </Global>
    
    # increase
    UseReverseDNS off
    IdentLookups off
    
    # Logging formats
    LogFormat default "%h %l %u %t \"%r\" %s %b"
    LogFormat auth "%v [%P] %h %t \"%r\" %s"
    LogFormat write "%h %l %u %t \"%r\" %s %b"
    
    # activate logging
    
    # every login
    ExtendedLog /var/log/proftpd/ftp_auth.log AUTH auth
    
    # file/dir access
    ExtendedLog /var/log/proftpd/ftp_access.log WRITE,READ write
    
     
    Last edited: Nov 4, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post the output of
    Code:
    netstat -tap
    ? Please make sure your direwall doesn't block port 21.
     
  3. ilushkin

    ilushkin New Member

    i have same sitiation and here is my output:
    cat output
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 24293/mysqld
    tcp 0 0 *:81 *:* LISTEN 14397/ispconfig_htt
    tcp 0 0 server1.*****:domain *:* LISTEN 14643/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 14643/named
    tcp 0 0 *:smtp *:* LISTEN 27790/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 14643/named
    tcp6 0 0 *:imaps *:* LISTEN 6011/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 5913/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 5847/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 5955/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 14497/apache2
    tcp6 0 0 *:ftp *:* LISTEN 27842/proftpd: (acc
    tcp6 0 0 *:ssh *:* LISTEN 3215/sshd
    tcp6 0 0 *:smtp *:* LISTEN 27790/master
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 14643/named
    tcp6 0 0 *:https *:* LISTEN 14497/apache2
    tcp6 0 0 server1.******.c:ssh ::ffff:192.168.1.:37010 ESTABLISHED30543/sshd: **** [p
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please don't hijack other threads. Open a new one otherwise it will become too confusing.
     

Share This Page