proftpd questions, serverIdent

Discussion in 'Server Operation' started by TheRudy, Jul 20, 2006.

  1. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Hey

    Just saw today that when i login to ftp, i can see name of the ftp server(proftpd), linux distro (debian) and server IP

    Response: 220 ProFTPD 1.2.10 Server (Debian) [192.168.168.100]

    Now the funny thing is, i haven't changed a bit in ftp config file since installation of the server where i set Ident to something else and then it work.. I think this changed when i upgraded ISPConfig, don't know why.. Or maybe when i fixed that warning message that proftpd is already in use..

    any ideas of what's going on? I tried changing settings below, restarting ftp and still the same..

    config file, always the same..
    Code:
    DefaultRoot ~
    RootLogin off
    IdentLookups off
    ServerIdent on "FTP Server ready."
    UseReverseDNS off
    
     
  2. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig doesn't change the ServerIdent directive.

    Can you post your full /etc/proftpd.conf here?
     
  3. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    sure thing:

    proftpd.conf
    Code:
    ServerName                      "Debian"
    ServerType                      standalone
    DeferWelcome                    off
    
    MultilineRFC2228                on
    DefaultServer                   on
    ShowSymlinks                    on
    
    TimeoutNoTransfer               600
    TimeoutStalled                  600
    TimeoutIdle                     1200
    
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                     "-l"
    
    DenyFilter                      \*.*/
    
    Port                            21
    
    MaxInstances                    30
    
    User                            nobody
    Group                           nogroup
    
    
    Umask                           022  022
    AllowOverwrite                  on
    
    DefaultRoot ~
    RootLogin off
    IdentLookups off
    ServerIdent on "FTP Server ready."
    UseReverseDNS off
    
    Include /etc/proftpd_ispconfig.conf
    
    proftpd_ispconfig.conf
    Like i said, i haven't changed anything from the time when i installed server ,well, i did change IdentLookups to off cause i had slow commands problem. Think till helped me there..
     
  4. falko

    falko Super Moderator ISPConfig Developer

    And this is the configuration from 192.168.168.100? Did you restart Proftpd?
     
  5. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    It is configuration from that IP and yes, i restarted ftp multiple times.. No change.. Weird or what? It's like it doesn't register ServerIdent on "FTP Server ready." or it overwrites it somewhere..
     
  6. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    You know what's the problem?

    DefaultAddress 127.0.0.1 in proftpd_ispconfig.conf file
    Chenged ip to 192.168.168.100 doesn't help..

    Commenting it out it and the message i get when i login to FTP is:
    Code:
    Response:	220 FTP Server ready.
    Of course now i get that ugly warning that its already been in use by "Debian" when i restart FTP server..
     
  7. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    ups, mistake.. 127.0.0.1 as DefaultAddress doesn't give any error on restart while it outputs the default info of the FTP server..

    Commented out (127.0.0.1) or with 192.168.168.100 ip as defaultAddress it does give me an warning on ftp restart but it displays serverident correctly..
     
  8. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Right, i think i got it solved now!

    I switched IP's!

    Before, default file:
    Code:
    ###################################
    #
    # ISPConfig proftpd Configuration File
    #         Version 1.0
    #
    ###################################
    DefaultAddress 127.0.0.1
    <VirtualHost 192.168.168.100>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    
    Changed file:
    Code:
    ###################################
    #
    # ISPConfig proftpd Configuration File
    #         Version 1.0
    #
    ###################################
    DefaultAddress 192.168.168.100
    <VirtualHost 127.0.0.1>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    
    On restart it doesn't give me any warnings like before.. ServerIdent works!
     
  9. falko

    falko Super Moderator ISPConfig Developer

    I'll check that.
     
  10. Ben

    Ben ISPConfig Developer ISPConfig Developer

    But switching IPs will result in using the global umask 022 instead of the 002 from the vhost, because the namespace for umask 002 is only for the vhost on IP 127.0.0.1

    So if that works with switching IPs it seems that the global IdentLookups and ReverseDNS stuff won't affect the vhost options, so inserting both in the vhost should help?
     

Share This Page