proftpd problems

Discussion in 'Installation/Configuration' started by SheePOnE, Oct 19, 2006.

  1. SheePOnE

    SheePOnE New Member

    Hi all,

    yesterday I installed ISPConfig 2.2.7 on Strato-Server by using the perfect howto.

    Everything works fine, only the proftpd makes some stress.

    here my config-file

    Code:
    #
    # /etc/proftpd.conf -- This is a basic ProFTPD configuration file.
    # To really apply changes reload proftpd after modifications.
    #
    
    ServerName                      "Debian"
    ServerType                      standalone
    DeferWelcome                    off
    
    MultilineRFC2228                on
    DefaultServer                   on
    ShowSymlinks                    on
    
    TimeoutNoTransfer               600
    TimeoutStalled                  600
    TimeoutIdle                     1200
    
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                     "-l"
    
    DenyFilter                      \*.*/
    
    DefaultRoot ~
    IdentLookups off
    ServerIdent on "FTP Server ready!"
    
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    #PersistentPasswd               off
    
    # Uncomment this if you would use TLS module:
    #TLSEngine                      on
    
    # Uncomment this if you would use quota module:
    #Quotas                         on
    
    # Uncomment this if you would use ratio module:
    #Ratios                         on
    
    # Port 21 is the standard FTP port.
    Port                            21
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances                    30
    
    # Set the user and group that the server normally runs at.
    User                            nobody
    Group                           nogroup
    
    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask                           022  022
    # Normally, we want files to be overwriteable.
    AllowOverwrite                  on
    
    # Delay engine reduces impact of the so-called Timing Attack described in
    # http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
    # It is on by default.
    #DelayEngine                    off
    
    
    Include /etc/proftpd_ispconfig.conf
    
    
    
    proftpd_ispconfig.conf
    Code:
    ###################################
    #
    # ISPConfig proftpd Configuration File
    #         Version 1.0
    #
    ###################################
    DefaultAddress 127.0.0.1
    <VirtualHost 85.XXX.XX.XXX>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    
    

    Code:
    /etc/init.d/proftpd restart
    Restarting ProFTPD ftp daemon.proftpd.
    .. - setting default address to 127.0.0.1
    proftpd.
     done.
    
    Code:
    ftp localhost
    Connected to localhost.
    220 FTP Server ready!
    Name (localhost:root):
    
    my Problem is, that noboy can't login an in services ftp is still offline.

    !?

    greets
    simon
     
    Last edited: Oct 19, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that you get the correct hostname of your server when you execute:

    hostname -f

    Also make sure that this hostname is listed in your /etc/hosts file.
     
  3. SheePOnE

    SheePOnE New Member

    /etc/hosts
    Code:
    85.XXX.XX.XXX   hXXXXXX.serverkompetenz.net hXXXXXX
    

    hostname -f
    hXXXXXX.serverkompetenz.net

    i think there is no wrong entry
     
    Last edited: Oct 19, 2006
  4. SheePOnE

    SheePOnE New Member

    any ideas!?
     
  5. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well the VMWare IPSCOnfig o nmy box has
    DefaultRoot ~

    at the pre last line before the inlcude in the proftpd.conf

    maybe that helps..
     
  6. SheePOnE

    SheePOnE New Member

    i fixed the problem

    old one
    Code:
    # special IPv6 addresses
    ::1      localhost  ipv6-localhost ipv6-loopback
    
    new one
    Code:
    # special IPv6 addresses
    ::1     ipv6-localhost ipv6-loopback #localhost
    
    but....why makes IPv6 so much stress?
     

Share This Page