proftpd problems

Discussion in 'Installation/Configuration' started by Ovidiu, Sep 20, 2005.

  1. Ovidiu

    Ovidiu Active Member

    proftpd seems not be running anymore, if Itry /etc/init.d/proftpd start I get the following error:

    Code:
    root@hxxxx:~# /etc/init.d/proftpd start
    Starting ProFTPD ftp daemon:  - getaddrinfo 'hxxxx' error: Name or service not known
     - warning: unable to determine IP address of 'hxxxx'
     - getaddrinfo 'hxxxx' error: Name or service not known
     - warning: unable to determine IP address of 'hxxxx'
    proftpd.
    root@hxxxx:~#
    
    Also thereis a logentry
    Code:
    Sep 20 22:44:44 h5810 proftpd[3533]: socket() failed in connection initialization: Address family not supported by protocol
    I knowtheabove problems come from me wanting to rename my machine, at least correct my machines name, but where is proftpd looking? I mean I already havea post explaining that hxxxx.serverkompetenz.net is my hostname and my domain, I can't just simply split it into host:hxxxx and domain:serverkompetenz.net thats not working...

    But if I enter hxxxx.serverkompetenz.netfor host and domain sometimes the mailsystem tries to do it like this: hxxxx.serverkompetenz.net.hxxxx.serverkompetenz.net and that will not work.
     
  2. Ovidiu

    Ovidiu Active Member

    I tried a grep -i -R 'hxxxx' /etc

    Code:
    root@hxxxx:~# grep -i -R 'hxxxx' /etc
    grep: Warnung: /etc/network/run: Rekursive Verzeichnisschleife.
    
    grep: /etc/rcS.d/S35devpts.sh: Datei oder Verzeichnis nicht gefunden
    Übereinstimmungen in Binärdatei /etc/ssh/ssh_host_key.
    /etc/motd:Linux hxxxx 2.4.29 #3 SMP Tue Feb 15 01:47:49 CET 2005 i686 GNU/Linux
    /etc/hostname:hxxxx
    /etc/hosts:81.xxx.xxx.xxx        hxxxx.serverkompetenz.net
    /etc/mailname:hxxxx.serverkompetenz.net
    /etc/motd.old:Linux hxxxx 2.4.29 #3 SMP Tue Feb 15 01:47:49 CET 2005 i686 unknown
    /etc/postfix/main.cf:myhostname = hxxxx.serverkompetenz.net
    /etc/postfix/main.cf.orig:myhostname = hxxxx.serverkompetenz.net
    /etc/postfix/local-host-names:hxxxx
    /etc/postfix/local-host-names:localhost.hxxxx
    /etc/postfix/local-host-names:hxxxx.serverkompetenz.net
    /etc/postfix/local-host-names~:hxxxx
    /etc/postfix/local-host-names~:localhost.hxxxx
    Übereinstimmungen in Binärdatei /etc/aliases.db.
    Übereinstimmungen in Binärdatei /etc/sasldb2.
    /etc/webalizer.conf:HostName    hxxxx
    /etc/webalizer.conf:HideSite    *hxxxx
    /etc/webalizer.conf:HideReferrer        hxxxx/
    root@hxxxx:~#
    
    sorry I tried to edit, instead clicked on quote ;-(

    I found that /etc/hostname was still hxxxx => changed to hxxxx.serverkompetenz.net did the trick : all is fine now, except for this log excerpt:

    Code:
    Sep 20 23:44:49 hxxxx /usr/sbin/cron[663]: (root) WRONG INODE INFO (crontabs/root)
     
    Last edited: Sep 20, 2005
  3. falko

    falko Super Moderator ISPConfig Developer

    I think you're running Debian. There must be a file /var/spool/cron/crontabs/root. Copy the contents from it, delete that file, and then recreate it simply by running
    Code:
    crontab -e
    as root and pasting the contents of the old file into it. That should solve the problem.
     
  4. Ovidiu

    Ovidiu Active Member

    after following your instructions how can I check if its ok now besides looking into my logfiles for that crontab entry I had before?

    I do not really trust my vi editing abilities and unforunately thats the editor crontab calls ;-) although I guess I could change that too.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Besides looking into your logfiles? :confused: I'd look into the logfiles... :D
     
  6. Ovidiu

    Ovidiu Active Member

    :D you know what I mean, something like crontab -c

    -c like check, maybe combined with a -v like in verbose ;)

    I guess this a the reason why my statistics do not get compiled too.
    I`ll wait until midnight and see what happens
     
    Last edited: Sep 21, 2005

Share This Page