ProFtpd problem

Discussion in 'Installation/Configuration' started by ppeelen, Sep 22, 2007.

  1. ppeelen

    ppeelen New Member

    Hi,

    I have installed ISPConfig for the first time for three days ago, but I am experiencing some problems.

    I added to my /etc/proftpd.conf the following:
    Code:
    UseReverseDNS off
    IdentLookups off
    PassivePorts 54002 54003
    but stills my FTP is extremly slow or not working at all. My ISP has blocked all ports up to 54000, and I am using 54001 for my ISPConfig.

    When checking the detail given by my FTP Client, it seems that ProFTPd is ignoring the PassivePorts:
    Code:
    Transmit 3.5.6 Session Transcript
    LibNcFTP 3.1.9 (March 19, 2005) compiled for UNIX
    Uname: Darwin|paul-peelens-imac-g5.local|8.10.0|Darwin Kernel Version 8.10.0: Wed May 23 16:50:59 PDT 2007; root:xnu-792.21.3~1/RELEASE_PPC|Power Macintosh
    Remote server is running ProFTPD.
    220: ProFTPD 1.3.0 Server (Debian) [***.***.***.***]
    Connected to www.****.com.
    Cmd: USER web10_paul
    331: Password required for web10_paul.
    Cmd: PASS xxxxxxxx
    230: User web10_paul logged in.
    Logged in to www.****.com as web10_paul.
    Cmd: SYST
    215: UNIX Type: L8
    Cmd: PWD
    257: "/" is current directory.
    Cmd: CWD /
    250: CWD command successful
    Cmd: PWD
    257: "/" is current directory.
    Cmd: PASV
    227: Entering Passive Mode (***,***,***,***,168,130).
    Data connection timed out.
    Falling back to PORT instead of PASV mode.
    Cmd: PORT 192,168,1,3,238,6
    200: PORT command successful
    Cmd: LIST
    425: Unable to build data connection: Connection refused
    Cmd: NOOP
    200: NOOP command successful
    Cmd: PORT 192,168,1,3,238,7
    200: PORT command successful
    Cmd: LIST
    425: Unable to build data connection: Connection refused
    According the the passiveports description found thrue google, the passive port get calculated by (p1*256)+p2. In this case (168*256)+130 = 43138, which is now 54002 or 54003.

    I have read my fair share of explainment about how passiveports works, but it seems that either I am forgetting something or that something is wrong.
    Could someone please help me with this problem.

    Thanks!

    /Paul Peelen
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried active transfers in your FTP client?
     
  3. ppeelen

    ppeelen New Member

    Yes, and those aren't working either.
     
  4. Gimly

    Gimly Member

    Hello everybody,

    I have the same problem with connexion on proftpd, it's very slow in active or passive mod but when it connected it work fine, this is my /etc/proftpd/proftpd.conf :

    and this is the nslookup for my server :

    If anyone have an idea why it's slowly for connexion ?

    Thank you for your answers :)
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to change:

    Code:
    Include /etc/proftpd_ispconfig.conf
    
    DefaultRoot ~
    ServerIdent on "Serveur FTP pret !"
    
    IdentLookups off
    UseReverseDNS off
    to:

    Code:
    
    DefaultRoot ~
    ServerIdent on "Serveur FTP pret !"
    
    IdentLookups off
    UseReverseDNS off
    
    Include /etc/proftpd_ispconfig.conf
    
     
  6. Gimly

    Gimly Member

    The problem persist ... erf :/
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Can you change
    Code:
    DelayEngine on
    to
    Code:
    DelayEngine off
    ?
     
  8. Gimly

    Gimly Member

    Oups, sorry for answer too late. The delay option is off and the problem persist. I've search on google and I don't find solution. If anyone have an other idea ?

    thanks
     

Share This Page