proftpd on OPENSUSE 11.1

Discussion in 'HOWTO-Related Questions' started by cepiolidus, Jul 13, 2009.

  1. cepiolidus

    cepiolidus New Member

    I installed proftpd on my opensuse 11.1 and since I needed a personal FTP server, I followed the steps on "THE PERFECT SERVER" series.
    I installed proftpd-1.3.2a, and everything on the installation went perfect, but when I try to log, after accepting the user name and password, it stops and I have this output: (from filezilla)

    Code:
    Status:	Connecting to 173.9.150.165:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220 Shark Signs Server
    Command:	USER (*******)
    Response:	331 Password required for (********)
    Command:	PASS ********
    Response:	230 User (*******) logged in
    Command:	SYST
    Response:	215 UNIX Type: L8
    Command:	FEAT
    Response:	211-Features:
    Response:	 MDTM
    Response:	 MFMT
    Response:	 MFF modify;UNIX.group;UNIX.mode;
    Response:	 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
    Response:	 REST STREAM
    Response:	 SIZE
    Response:	211 End
    Status:	Connected
    Status:	Retrieving directory listing...
    Command:	PWD
    Response:	257 "/" is the current directory
    Command:	TYPE I
    Response:	200 Type set to I
    Command:	PASV
    Response:	227 Entering Passive Mode (173,9,150,165,221,181).
    Command:	LIST
    Error:	Connection timed out
    Error:	Failed to retrieve directory listing
    The username has been *** for security reasons.

    This is my proftpd.conf

    Code:
    ServerName			"Shark Signs Server"
    ServerType			standalone
    DefaultServer			on
    
    Port				21
    
    UseIPv6				off
    
    Umask				022
    
    MaxInstances			30
    
    User				nobody
    Group				ftp-users
    
    
    AllowOverwrite		on
    
    <Limit SITE_CHMOD>
      DenyAll
    </Limit>
    
    
      UserAlias			anonymous ftp
    
      MaxClients			10
    
      DisplayLogin			welcome.msg
      DisplayChdir			.message
    
    #  <Limit WRITE>
    #    DenyAll
    #  </Limit>
    
    DefaultRoot ~
    IdentLookups off
    ServerIdent on "Shark Signs Server"
    
    TimeoutNoTransfer 900
    
    Does anybody know how to resolve that MLSD problem?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client?
     
  3. cepiolidus

    cepiolidus New Member

    Ok, so I found the problem It was the firewall. I had to disable it completely and the FTP works.
    The question is, how can I add Profftpd to the list of programs in the drop down menu in the firewall? I tried adding the port 21, and it did not work.

    Thanks for any help
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Where? In YaST, or in ISPConfig, or anywhere else?
     
  5. cepiolidus

    cepiolidus New Member

    yes in yast. When I go to firewall setting there is a list of programs to be bypassed by the firewall, but proftpd is not in the list.
    Any suggestions?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's listed there? FTP maybe?
     
  7. cepiolidus

    cepiolidus New Member

    these are the things listed in the allowed services (I only have samba server, netbios server, and http server, selected to be allowed)
    DHCP SERVER
    FTTPS SERVER
    MySQL SERVER
    NFS CLIENT
    NFS SERVER SERVICE
    NIS CLIENT
    SMTP with postfix
    SAMBA CLIEN
    SECURE SHELL SERVER
    VNC
    VNC SERVER
    VNC Mini-http server
    Zeroconf/bonjour multicast DNS
    cups
    dnsmasq
    dnsmasq (dnsmasq-dns)
    svnserve
    vsftpd Server (which I tried adding and did not work)
    xdmcp
    xntp server

    How do I add proftpd to this list?

    and also, is there a good gui for proftpd?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Unfortunately I'm no SUSE expert... :(
     

Share This Page