proftpd not working with external ftp client.

Discussion in 'HOWTO-Related Questions' started by webdbywill, Feb 1, 2007.

  1. webdbywill

    webdbywill New Member

    I'm not sure what the problem is here. I can ftp from within the ispconfig interface.

    However if i try to use an external ftp client such as my browser or smartftp things like that. I can connect but it just hangs when it ties to get the folder list. Any help would be greatly appreciated.

    I do appologize if this is a duplicate thread. I did search for an answer first. Didn't find anything that addressed this problem.

    I'm using proftpd with ispconfig (obviously) and suse 10.2.

    Thank You.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try active and passive FTP mode in your FTP client.
  3. webdbywill

    webdbywill New Member

    I trid both active and passive transfers. Both with the same result as described in the problem. Any other ideas?
  4. Hans

    Hans Moderator ISPConfig Developer

    Is the line:

    Include /etc/proftpd_ispconfig.conf

    at the end of your /etc/proftpd.conf file?

    Recently, i lost that line due a update of proftp.

    When i added the line again, proftp was functioning again..
    If you change something within your /etc/proftpd.conf do not forget to restart proftp.
  5. webdbywill

    webdbywill New Member

    I just checked to make sure that the line was at the end of the proftpd.conf and restarted proftpd. The line was there though.

    # This is a basic ProFTPD configuration file (rename it to # 'proftpd.conf' for actual use. It establishes a single server# and a single anonymous login. It assumes that you have a user/group# "nobody" and "ftp" for normal operation and anon. ServerName "ProFTPD Default Installation"ServerType standaloneDefaultServer on # Port 21 is the standard FTP port.Port 21 # Umask 022 is a good standard umask to prevent new dirs and files# from being group and world writable.Umask 022 # To prevent DoS attacks, set the maximum number of child processes# to 30. If you need to allow more than 30 concurrent connections# at once, simply increase this value. Note that this ONLY works# in standalone mode, in inetd mode you should use an inetd server# that allows you to limit maximum number of processes per service# (such as xinetd).MaxInstances 30 # Set the user and group under which the server will run.User nobodyGroup nogroup # To cause every FTP user to be "jailed" (chrooted) into their home# directory, uncomment this line.DefaultRoot ~ # Normally, we want files to be overwriteable.AllowOverwrite on # Bar use of SITE CHMOD by default## DenyAll# # A basic anonymous configuration, no upload directories. If you do not# want anonymous users, simply delete this entire section. User ftp Group ftp # We want clients to be able to login with "anonymous" as well as "ftp" UserAlias anonymous ftp # Limit the maximum number of anonymous logins MaxClients 10 # We want 'welcome.msg' displayed at login, and '.message' displayed # in each newly chdired directory. DisplayLogin welcome.msg DisplayFirstChdir .message # Limit WRITE everywhere in the anonymous chroot DenyAll DefaultRoot ~IdentLookups offServerIdent on "FTP Server ready." Include /etc/proftpd_ispconfig.conf

    The above is what my proftpd.conf file has in it.
  6. falko

    falko Super Moderator ISPConfig Developer

    Uhm... Can you post the contents again, but this time wrap CODE tags around it? Because right now nobody can read it.
  7. webdbywill

    webdbywill New Member

    It's no problem. I got it working. It was a firewall issue. for some reason it just didn't like my router's built in firewall.

    I disabled that one and enabled the ispconfig firewall. all is working fine now.

    THank you.

Share This Page