proftpd no longer working

Discussion in 'Server Operation' started by White, Dec 10, 2011.

  1. White

    White Member

    i can no longer use my ftp client as it will not connect to my server.

    If i try a restart on /etc/init.d/proftpd restart this happens
    server1:~# /etc/init.d/proftpd restart
    Stopping ftp server: proftpd.
    Starting ftp server: proftpd - warning: unable to determine IP address of ''
     - error: no valid servers configured
     - Fatal: error processing configuration file '/etc/proftpd/proftpd.conf'
    the ip address is192.168.2.4 of my server and everything else is using this ip address fine.

    now i have been mucking about with postfix as some who have read my other threads may know to get my emails working. Could there be a link as there seems to be in /etc/default/sasauthd and i have changed some settings in there

    please can anyone help
  2. White

    White Member


    ok when i did

    hostname -f
    unknown host
    so i checked my hosts file and low and behold an extra "." had appeared and it looked like this

    PHP: server1
    i removed the "." and hostname -f returned
    all is now well and back up and running fine. the strange thing is this has happened since the 8/12/2011 as the ftp log shows all well till then, no i hadf been messing with postfix settings last week so it seems strange this extra "." has appeared from nowhere.
    Last edited: Dec 11, 2011

Share This Page