Proftpd + MySQL virtual users, can't connect

Discussion in 'HOWTO-Related Questions' started by geekman, Aug 4, 2007.

  1. geekman

    geekman New Member

    Is it possible to have MD5 encryptions on passwords at all? At least anything other than plaintext, my mailserver already uses ENCRYPT in mysql whatever encryption that is, but i'd like to use MD5 on FTP (if you could advise on postifx/courier too that'd rock)

  2. falko

    falko Super Moderator ISPConfig Developer

    Are you referring to Proftpd or Pureftpd? The Pureftpd guide uses MD5 passwords, but I'm not aware of a way to do this with Proftpd... :(
  3. geekman

    geekman New Member

    I was referring to proftpd...blah :(. Can you recommend a decent form of encryption that could be used across most daemons (ftp, mail, etc..) I guess I could have the password stored in the database using multiple records each one with a different encryption...but I don't exactly want to do that.

  4. falko

    falko Super Moderator ISPConfig Developer

    Unfortunately no... :(
  5. MrMagix

    MrMagix New Member

  6. MrMagix

    MrMagix New Member

    I just found the time to set up the hashed password storage and it worked.

    I didn't had openssl installed, a apt-get install openssl worked for me.
  7. dragon

    dragon New Member

    ProFTPD 1.3.0 with MySQL and MD5 hash on Debian Etch 4.0

    Hi all,

    this comes a bit late :), but I hope someone can use this information.

    1. ProFTPD fully supports MySQL authentication with MD5 hashes - the same used by Linux and UNIX systems in the /etc/shadow file. To use it, enter the following directive in your proftpd.conf file along with all other SQL directives:

    SQLAuthTypes Crypt Plaintext

    (You can probably skip the Plaintext if everything with hashes is working fine and you don't need fallback. I will update you on that later :)).

    2. When you get a message saying "FTP session requested from unknown class" on Debian Etch 4.0 (ProFTPD Version 1.3.0) and you are trying to use MySQL authentication, this is probably due to the

    LoadModule mod_sql_postgres.c

    in /etc/proftpd/modules.conf file, which line should be commented out.
    I see this as a bug in the proftpd package, since I have NOT installed the proftpd-pgsql package, so this line should not be present, and also, at least it shouldn't affect the work of the proftpd-mysql package, which is successfully installed.

    I would like to thank Falko for this line, mentioned in his tutorial (see up).
  8. Franzus

    Franzus New Member


    that uncomment of postgresql worked for me

    Thanks a lot!
  9. dusktrader

    dusktrader New Member

    THANK YOU -- this also fixed my issue immediately. I was tearing my hair out after an upgrade to the latest dapper 6.0.6 release in repo, which is proftpd 1.3.0-9~dapper1

    Just comment out the line listed above and restart proftpd. Started working correctly right away after that.

Share This Page