Proftpd-Mysql on Ubuntu Breezy

Discussion in 'Installation/Configuration' started by Yabadoo, Aug 6, 2007.

  1. Yabadoo

    Yabadoo Member

    I'am running a server with Ubuntu Breezy on it.
    It's running for more than a year now and it's just running perfect,
    but i want to install proftpd-mysql, and this is not going the way i want.
    Below you will find the errors, the errors are probbally because breezy is stopped.

    Is there a workaround to install proftpd-mysql and proftpd-common.

    prompt:~# apt-get install proftpd-mysql
    Reading package lists... Done
    Building dependency tree... Done
    The following extra packages will be installed:
    Suggested packages:
    The following NEW packages will be installed:
    proftpd-common proftpd-mysql
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    Need to get 573kB of archives.
    After unpacking 1573kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    WARNING: The following packages cannot be authenticated!
    proftpd-mysql proftpd-common
    Install these packages without verification [y/N]? y
    Err breezy/universe proftpd-mysql 1.2.10-22
    404 Not Found [IP: 80]
    Err breezy/universe proftpd-common 1.2.10-22
    404 Not Found [IP: 80]
    Failed to fetch 404 Not Found [IP: 80]
    Failed to fetch 404 Not Found [IP: 80]
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

    Please advise,

    Kind Regards,

    I don't want to upgrade to Dapper
  2. geekman

    geekman New Member

    If the package were discontinued I wouldn't think it would find it then try to install it, only to not find the URL. I would try running apt-get update if it still tries to install then obvious it's not meant to be discontinued and is probably broken some how at that repository server. Also, try seeing if using another set of sources and see if it works with them. You could always just search for the package name it's trying to find on google and install that manually with dpkg -i <file>. Or even compile it from the source code.

    A quick search and I think I found the package you want...

    Just fetch that with wget and use dpkg, could have dependencies though :(
    On second though, dpkg should handle those dependencies...I think, I can't remember exactly.

  3. falko

    falko Super Moderator ISPConfig Developer

  4. Yabadoo

    Yabadoo Member

    Oke Geekman,

    I will first try this in vmware to see if this will work.
    I just need to be sure for the dependencies, otherwise it will not work i believe.

    Thanks for the reply
  5. Yabadoo

    Yabadoo Member

    I also found this out that al the repositories are gone, but i don't want to run the risk to upgrade to a newer version. I need to run php4, and i'am not sure when i do an total upgrade of the system this would keep on running.
    Is there some other way to instal proftpd-mysql ?
  6. Yabadoo

    Yabadoo Member

    I tried to install with dpkg -i <file> but there comes the dependencies problem. Below you will find the output.
    First i tried to install proftpd-mysl
    dpkg -i proftpd-mysql_1.2.10-22_i386.deb
    (Reading database ... 27968 files and directories currently installed.)
    Preparing to replace proftpd-mysql 1.2.10-22 (using proftpd-mysql_1.2.10-22_i386.deb) ...
    Unpacking replacement proftpd-mysql ...
    dpkg: dependency problems prevent configuration of proftpd-mysql:
    proftpd-mysql depends on proftpd-common (= 1.2.10-22); however:
    Package proftpd-common is not configured yet.
    dpkg: error processing proftpd-mysql (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:

    After that i downloaded proftpd-common
    dpkg -i proftpd-common_1.2.10-22_i386.deb
    (Reading database ... 27968 files and directories currently installed.)
    Preparing to replace proftpd-common 1.2.10-22 (using proftpd-common_1.2.10-22_i386.deb) ...
    Unpacking replacement proftpd-common ...
    dpkg: dependency problems prevent configuration of proftpd-common:
    proftpd-common depends on proftpd | proftpd-mysql | proftpd-pgsql | proftpd-ldap; however:
    Package proftpd is not installed.
    Package proftpd-mysql is not configured yet.
    Package proftpd-pgsql is not installed.
    Package proftpd-ldap is not installed.
    dpkg: error processing proftpd-common (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:

    I downloaded all the packages dpkg is asking for, is there a way to install them all in one time or do i have to do it on another way?

    Please advise.
  7. geekman

    geekman New Member

    You can always download the source code and compile it manually, but I don't see why you can't upgrade to 6.10 or newer even, it shouldn't hurt your php installation since they are two different packages on the system...i'm pretty sure, might need someone to confirm that.

    I'm following this guide to upgrade my oldest box which runs 5.10 because I ran into the same issue as there...but I haven't finished downloading all the packages yet.


Share This Page