Proftpd MasqueradeAddress Virtaulhosts question

Discussion in 'Server Operation' started by Guido64, Aug 10, 2008.

  1. Guido64

    Guido64 New Member


    I read on howtoforge and several other sites up and down about the problem nothing helped me so far. After pulling all my hair out i'm putting my problem here in the forum and hope somebody can help.

    Few things you maybe need to know:
    -I'm running proftpd on a Openvz VPS.
    -My router/firewall is m0n0wall 1.3b13
    -I can't reach my public external IP address just because m0n0wall/freebsd doesn't allow it (

    Because proftpd is behind m0n0wall NAT router there is a problem with passive FTP connection.

    When I add "MasqueradeAddress [my_public_ip]" to the proftpd.conf this problem is solved. But then I have a problem connecting local clients to proftpd with passive ports enabled because my external public ip is not reachable on the lan side.

    Wen I try to setup a Virtualhost for local users and a virtualhost for external users i can't get it to work. I thought virtualhosts in proftpd was like apache were i can give one ip address more hostnames with the same tcp port. But with proftpd I receive errors like "address already in use" or "port already in use"

    "DefaultAddress" doesn't help
    "SocketBindTight on" doesn't help

    Can I configure 2 virtualhosts like and on the same (vps)system with both using port 21 and both using the same IP, just like apache can?

    So external users get the virtualhost config with, for exmaple, the MasqueradeAddress direction and internal users get the virtualhost without the MasqueradeAddress direction?

    I don't like to explain users to use active FTP over and over again I would like to fix the passive FTP ports problem instead.

Share This Page