proftpd login problem with list

Discussion in 'Installation/Configuration' started by Cirox, Mar 18, 2006.

  1. Cirox

    Cirox New Member

    Hi,

    when i or a user log in with the ftp password, proftpd takes a while to show the directories. The login hangs on the "List" command. There is a little break up to 1 second. But there is no regularity in it. Sometimes the login process is very fast.

    I googled and tryed the command "DelayEngine = off", but after restart nothing is better.

    Whats the problem and how to solve it ?

    greetings cirox
     
  2. falko

    falko Super Moderator

    Have you tried both active and passive mode in your ftp client?
     
  3. Cirox

    Cirox New Member

    Hi,

    yes of course. Thats what i tried, too:

    I add the following lines and restart the ftp server

    /etc/proftpd.conf:

    <global>
    IdentLookups off
    DelayEngine off
    </global>

    thats right ?, because there was no global section .....

    but no change in the speed of directory listing.

    greetings cirox
     
    Last edited: Mar 19, 2006
  4. Cirox

    Cirox New Member

    Hi,

    :) problem solved ....

    i simply add this at /etc/proftpd.conf and restarted the server ;-) after changing the servername in /ets/hostname from srv.example.com to srv.

    UseReverseDNS off

    and everything works like a harm. But i takes 12 h to find out for me. At the other site /etc/hostname /hostname /etc/resolv.conf have to have the right dns settings just like bind9.

    greetings cirox
     

Share This Page