Proftpd Inside Network (Very Slow)

Discussion in 'Installation/Configuration' started by zer0_g666, Dec 31, 2005.

  1. zer0_g666

    zer0_g666 ISPConfig Developer

    Proftpd works perfectly outside the network but inside it is very slow, it always takes 8seconds to upload a file, i was wondering if this is normal? .. or is there some i can change to fix this ?

    Cheers
     
  2. falko

    falko Super Moderator

    Where is proftpd located? Inside or outside your network? Have you tried both active and passive mode?
    What's in /var/log/xferlog?
     
  3. till

    till Super Moderator

    If you have hostname lookups enabled in your proftpd.conf, try to disbale it.
     
  4. zer0_g666

    zer0_g666 ISPConfig Developer

    Im on the same network as the server, i.e. server ip 192.128.0.2 and me pc 192.128.4, both active and passive are the same.

    its not the actual speed of the file transfers its the time it takes to exe a command, it always takes 8 seconds before it will start the transfer and 8 seconds just for a dir listing.

    In the xferlog it doesnt seem to show any errors at all ... :confused:

    Outside my network where my server ip would be 80.127.122.*** the ftp server works fine, nice and fast, i was just wondering if its because im working on the same network and there is a fix i can apply or if a fault .....

    Cheers
     
  5. zer0_g666

    zer0_g666 ISPConfig Developer

    Ive tried both on and off and it doesnt seem to make any difference :confused:
     
  6. falko

    falko Super Moderator

    Maybe it's the firewall on your workstation that's causing the problem. Have you tried to disable it?
     
  7. zer0_g666

    zer0_g666 ISPConfig Developer


    Yea, ive got zonealarm pro and its the same even when disabled ... :(
     
  8. till

    till Super Moderator

    Did you have a low transfer rate or did it take very long when you connect to the FTP server?
     
  9. zer0_g666

    zer0_g666 ISPConfig Developer

    the transfers are fast its just the commands take ages to execute ...

    Status: Connecting to 192.168.0.4 ...
    Status: Connected with 192.168.0.4. Waiting for welcome message...

    (takes 8secs here)

    Response: 220 Gemini FTP Server ready.
    Command: USER web1_kd3sign
    Response: 331 Password required for web1_kd3sign.
    Command: PASS ********
    Response: 230 User web1_kd3sign logged in.
    Command: FEAT
    Response: 211-Features:
    Response: MDTM
    Response: REST STREAM
    Response: SIZE
    Response: 211 End
    Command: SYST
    Response: 215 UNIX Type: L8
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is current directory.
    Command: TYPE A
    Response: 200 Type set to A
    Command: PASV
    Response: 227 Entering Passive Mode (192,168,0,4,222,10).
    Command: LIST

    (takes 8secs here)

    Response: 150 Opening ASCII mode data connection for file list
    Response: 226 Transfer complete.
    Status: Directory listing successful
     
  10. falko

    falko Super Moderator

    Maybe it's the firewall on the FTP server... :confused: Please post the output of
    Code:
    iptables -L
     
  11. zer0_g666

    zer0_g666 ISPConfig Developer

    I fixed it, it was cos i didnt have the name servers setup correctly ... soon as i put in the right ip address it fixed it, now its fast :D

    cheers for your help
     
  12. timbo

    timbo New Member

    If you are having this problem! :

    I searched and searched for an answer to this.

    On a server running ProFTPd in certain configurations you can see a very slow load time (up to a minute or more) while listing the directory contents. This can be sped up greatly by adding these commands to the bottom of your ProFTPd configuration file. This is generally located in /etc/proftpd.conf:

    Code:
    IdentLookups off
    UseReverseDNS off
    ListOptions "" maxdepth 3
    ListOptions "" maxdirs 10
    ListOptions "" maxfiles 1000
    AllowOverride off
    Save the conf file and restart ProFTPd.
     

Share This Page