ProFTPd errors

Discussion in 'Server Operation' started by tlsuess, Oct 21, 2007.

  1. tlsuess

    tlsuess New Member

    Hi all,

    My name's Todd and I'm having a SERIOUS ERROR with ProFTPd. Just recently I upgraded my control panel from VHCS to ispCP (a VHCS fork) and I currently run ProFTPd-mysql as my FTP server. I am really losing sleep over this situation. Right now I cannot get it to start and it won't tell me why. Here's my proftpd.conf file:
    Code:
    #
    #	ispCP OMEGA ProFTPd config file
    #
    #
    #
    # Includes required DSO modules. This is mandatory in proftpd 1.3
    #
    #Include /etc/proftpd/modules.conf
    
    ServerName				"xetaspace"
    ServerType				standalone
    DeferWelcome			off
    
    ShowSymlinks			on
    MultilineRFC2228		on
    DefaultServer			on
    ShowSymlinks			on
    AllowOverwrite			on
    UseReverseDNS			off
    IdentLookups			off
    AllowStoreRestart		on
    AllowForeignAddress		on
    
    LogFormat 				traff "%b %u"
    
    TimeoutNoTransfer		600
    TimeoutStalled			600
    TimeoutIdle				1200
    
    DisplayLogin			welcome.msg
    DisplayFirstChdir		message
    
    #LsDefaultOptions 		"-l"
    
    DenyFilter				\*.*/
    
    DefaultRoot				~
    
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    #PersistentPasswd		off
    
    # Port 21 is the standard FTP port.
    
    Port					21
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    
    MaxInstances			30
    
    # Set the user and group that the server normally runs at.
    
    User					nobody
    Group					nogroup
    
    # Normally, we want files to be overwriteable.
    
    <Directory /*>
      # Umask 022 is a good standard umask to prevent new files and dirs
      # (second parm) from being group and world writable.
      Umask				022  022
    
      AllowOverwrite		on
      HideNoAccess 			on
    
    </Directory>
    
    <Limit ALL>
      IgnoreHidden 			on
    </Limit>
    
    <Global>
      RootLogin				off
      TransferLog			/var/log/proftpd/xferlog
      ExtendedLog 			/var/log/proftpd/ftp_traff.log read,write traff
      PathDenyFilter 		"\.quota$"
    </Global>
    
    #
    # ISPCP Managment;
    #
    #SQLBackend				mysql		# enable for proFTPd >= 1.3
    SQLAuthTypes 			Crypt
    SQLAuthenticate			on
    SQLConnectInfo			[email protected] vftp ********
    SQLUserInfo				ftp_users userid passwd uid gid homedir shell
    SQLGroupInfo			ftp_group groupname gid members
    SQLMinID				2000
    
    #
    # ISPCP Quota management;
    #
    
    QuotaEngine 			on
    QuotaShowQuotas 		on
    QuotaDisplayUnits 		Mb
    
    SQLNamedQuery			get-quota-limit SELECT "name, quota_type, per_session, limit_type, bytes_in_avail, bytes_out_avail, bytes_xfer_avail, files_in_avail, files_out_avail, files_xfer_avail FROM quotalimits WHERE name = '%{0}' AND quota_type = '%{1}'"
    SQLNamedQuery			get-quota-tally SELECT "name, quota_type, bytes_in_used, bytes_out_used, bytes_xfer_used, files_in_used, files_out_used, files_xfer_used FROM quotatallies WHERE name = '%{0}' AND quota_type = '%{1}'"
    SQLNamedQuery			update-quota-tally UPDATE "bytes_in_used = bytes_in_used + %{0}, bytes_out_used = bytes_out_used + %{1}, bytes_xfer_used = bytes_xfer_used + %{2}, files_in_used = files_in_used + %{3}, files_out_used = files_out_used + %{4}, files_xfer_used = files_xfer_used + %{5} WHERE name = '%{6}' AND quota_type = '%{7}'" quotatallies
    SQLNamedQuery			insert-quota-tally INSERT "%{0}, %{1}, %{2}, %{3}, %{4}, %{5}, %{6}, %{7}" quotatallies
    
    QuotaLock 				/var/run/proftpd/tally.lock
    QuotaLimitTable 		sql:/get-quota-limit
    QuotaTallyTable 		sql:/get-quota-tally/update-quota-tally/insert-quota-tally
    I tried removing and reinstalling ProFTPd with apt-get and still nothing works. I purged the config files and nothing at all. What really drives me up the wall is that when I run "/etc/init.d/proftpd start" it tells me it's starting but doesn't start. And there is nothing logged either! It's driving me insane. Please help! Any help is appreciated!

    Thanks,
    Todd
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you check all log files?
    What's the output of
    Code:
    netstat -tap
    ?
    Have you tried to manually run the command from the init script that actually starts Proftpd? I guess it will throw an error.
     
  3. rul3z

    rul3z New Member

    Can u give me the output of these commands:

    First
    Code:
    proftpd -t
    then
    Code:
    proftpd -n -c /etc/proftpd.conf
    finally
    Code:
    proftpd -d 5
     

Share This Page